Ski-Doo Snowmobiles Forum banner
relay
1-20 of 24 Results
  1. REV-XP / XM Chassis - Mountain Sleds
    recently purchased my first snowmobile in may 2020, i've regularly started the sled every few weeks over the summer. i found one time it wouldn't start and kept hearing the starter relay clicking therefore, tested the battery found it to be dead and replaced it (pull start does work and sled...
  2. Skandic / Expedition
    So I have a 2017 900 ace WT that I inherited from my late grandfather. It hasn’t given me any problems for 3 years besides a dirty fuel screen but now it doesn’t want to start. I hooked up a jumper pack to it and it fired right up so I thought “oh sweet maybe I just have to charge the battery”...
  3. REV-XP/XS Chassis: Renegades/Freeride/Backcountry
    Need some help! Last spring when I put my 2011 Rev XP 800 etec Renegade away, I used the summarization feature, removed the belt, put on my battery maintainer and put it on the stand. I rebuilt the primary clutch, put new hyfax on, couple idler wheels during the summer. Winter is nearing so I...
  4. Skandic / Expedition
    Hello I have a 2015 Expedition Sport 550f. I just wired a 12v plug and a visor jack into my starter relay. Now I am wondering if that was a good idea... Will having electrical accessories wired into the starter relay be an issue? The circuit is constant and the relay has a 30A fuse. Each of...
  5. 900 ACE 4-Stroke Models
    Hey Guys..... just looking for some opinions and to see if anyone else has run into this issue. My wife's '17 Enduro 900 has been running fine but it is doing something and I want to get ahead of it so it doesn't get worse on a trip. There have been two issues this season and I think I already...
  6. REV Chassis - Performance and Trail Models
    Hi Everyone - Last year my sled was momentarily losing power completely for a split second then coming back fine. It seemed random and mostly while cruising. Lost throttle, gauges, lights etc just for a second then they came right back - but enough to scare you when your a few hours away from...
  7. Skandic / Expedition
    Hello I am new to this forum. I am having trouble with my 2016 600 ace Expedition sport. When I have been out riding and shut down the machine it will not start I have learned that taking out the relays and warming them will at least allow me to restart the machine and until the machine has run...
  8. REV-XP/XS Chassis: Renegades/Freeride/Backcountry
    2015 Renegade Sport 600 Lost headlight and dash control panel. Electric start still works. I changed relay as recommended by some forums, but no change. All fuses good. Not sure where to look next. I would like to get my tester out and got through the electrical system, but would need a...
  9. REV Chassis - Performance and Trail Models
    Hey guys! Im new here but after weeks of frustration i am out of ideas. I have an 05 gtx 600 ho non-sdi, everything works on it except it wont charge the battery. The battery will hold a charge if you put it on a tender. At a full charge i can ride maybe two hours using my E-start, but after it...
  10. MXZ / Legend / Summit / Grand Touring / Formula
    Complete and total newbie here- I just replaced the mpem on my 99 summit 600 and she started up just fine. However, the headlights, brake light, gauges, and handwarmers do not work. After doing some research people said that it could be A.) A fuse B.) the relay or C) the voltage regulator. I do...
  11. REV Chassis - Performance and Trail Models
    Looking for some direction from you experienced sled owners that have had electrical problems. I picked up a used 07 Rev with 600 SDI elect start. Sled is running like a champ but in my last outing I blew 2 break lights and lost my thumb & hand warmers. We were sledding in negative 10 degree...
  12. REV Chassis - Performance and Trail Models
    Hey guys I have a 2003 rev 600ho starts first pull every time and runs mint just bought it two months ago it has a few mods including mbrp can but I've noticed when I start it up all the service lights on speedometer come on engine/exclamation mark/temp light and so on also the tac goes from...
  13. REV Chassis - Performance and Trail Models
    I have a 05 500ss with 5k miles on it, just picked it up this summer. Im having an intermittent electrical issue and was wondering if anybody had any ideas. I first noticed that i keep blowing the taillight running light, but brake light still works. I am on bulb number 4 in about 500 miles...
  14. REV Chassis - Performance and Trail Models
    so i have a charging problem on my sled. it is not my stator or my regulator. on the rd/bu wire i have my 13-14 volts. but this voltage will not go threw the relay and to the battery. i tested and checked the relay and all the fuses and also all the wires that go to the battery for shorts and...
  15. REV Chassis - Performance and Trail Models
    I am struggling to find the fix of my speedo issues on my 05 MXZ 600HO non SDI. Its not just the speedo. I the past when the speedo jumped to 135 mph it was a sign to change out the relay. Always had success.This time not so. I have tried 2 new relays and the problem persist. Hand warmers are...
  16. Skandic / Expedition
    Here is some updated and further verified electrical information for these machines - at the moment some of these only apply to the four strokes, as the ETEC and 550 have a totally different wiring harness. Other mods in here will work on nearly any Doo, or even other brands. Check the...
  17. Skandic / Expedition FAQ's
    Here is some updated and further verified electrical information for these machines - at the moment some of these only apply to the four strokes, as the ETEC and 550 have a totally different wiring harness. Other mods in here will work on nearly any Doo, or even other brands. Check the...
  18. REV Chassis - Performance and Trail Models
    After about a 1/2 ride I start to lose my dash lights when at idle they flicker, all the dummy lights light up and beeps. Completely lost my power was only reving about 7700 7800 max. I shut it down 5 mins later I start it up go to take off and it bogs right Down and basically have no power...
  19. REV Chassis - Performance and Trail Models
    Just need to be confirmed. My 07 mxz x every once in a while I'll try to start it and the run relay starts clicking. I tried replacing the relay the last time it did it, but it did the same thing. My dash doesn't lite up either. My battery voltage is at 12.8 12.9 so I don't think its the...
  20. Skandic / Expedition
    I've recently lost most of my lights (not burnt out), tach, oil temp and fuel gauge indications on my 2004 Skandic SUV (600LC). I still have headlights, both high and low (After 50km of riding since the problem first started), and one remaining speedo backlight. Since I have 12.5 vdc on the...
1-20 of 24 Results
Top