Ski-Doo Snowmobiles Forum banner
no start
1-15 of 15 Results
  1. MXZ / Legend / Summit / Grand Touring / Formula
    Hi all, Once again looking for some dootalk saviors. My 2000 Grand Touring 600 is having intermittent electric start issues. Sometimes it works and sometimes it is completely dead- no click, no sound, no nothing. During my trouble shooting, things got weird: Step 1- put a fresh battery in...
  2. MXZ / Legend / Summit / Grand Touring / Formula
    I bought the Summit X 670 last winter and only got a couple of chances to ride it. The first time it had water in the fuel from being left outside, but a little gas line antifreeze ran through it and it ran perfectly; had full power, started easily, and would idle on it's own. Now this year I've...
  3. REV-XP/XS Chassis: Renegades/Freeride/Backcountry
    First of all totally stoked on this sled, this is my first sled and I have fixed a couple things to get is running (jets, gas tank grommets, fuel hose) but it was running solid for awhile. Now i'm experiencing some odd electrical issues. Started with intermittent no start using electric start...
  4. REV Chassis - Performance and Trail Models
    Good day everyone, Fairly new poster here, but have been searching and reading tons on this great site. That being said, my particular problem I've been searching high and low on to find a solution and still have not been successful. Background: Around this time last year (Feb 2019), I had...
  5. REV-XR/XS Chassis: 4-TEC 1200 Perf. & Trail Models
    Hi all, I bought a used 2016 MXZ 1200 x at the end of last season. Haven't even ridden yet. I was trying to add LED light strips to it. Whatever I did the sled will no longer start. By not start I mean nothing. No click, no noise. While I was connecting the wiring for the LED lights I...
  6. REV Chassis - Performance and Trail Models
    I have a 2005 SDI MXZ 600. Rebuilt the engine due to a crank bearing out. Had to disconnect the fuel system to remove the engine. Now installed the engine and when you give the first pull, the fuel pump runs and the lights come on. The sled has great spark and will fire and run with a little...
  7. REV Chassis - Performance and Trail Models
    Hi there everyone. I am really out of touch with these sleds. I bought the sled for $900 and put a long track on it. Since iver owned it ive ridden it three times. The first time i actually rode it and got it to operating temp, I shut the machine off and it loses spark. So i brought it back to...
  8. 600 ACE 4-Stroke Models
    Hello and greetings from Finland! I am having issues with diagnosing a starting issue in a 2013 Tundra with the 600 ACE engine. When the start button is pressed you can hear two beeps and all the lights go up, fuel pump starts priming but the solenoid does not do anything. I jumped the B+...
  9. REV-XP/XS Chassis: Perf. Trail 120-129 Inch Models
    Hey folk, did clutch work and pipe on my buddies 2016 800 etec. reassembled dash plugged everything in, everything worked but add on LEDs. started and ran great down the trail. Buddy said he would check it out later wanted to get home. Trailered sled home one hour, sled was dead. no lights...
  10. REV Chassis - Performance and Trail Models
    I am new to the group. I have a 2003 MXZ 800 that will not start at the handlebar start switch. I can jump it at the starter solenoid and it will fire up. The handlebar kill switch will stop the motor. Any trouble shooting tips would be greatly appreciated. Thank you in advance.
  11. REV Chassis - Performance and Trail Models
    I'm new to dootalk, but I have done several mods to my 05' mxz x 800 that may interest some folks. Recently I removed the big clunky seat that my machine came with, and fabed a new seat frame to put a Ducati Monster seat on it. It turned out absolutely great (naked bike look). As a result of...
  12. REV-XP/XS Chassis: Perf. Trail 120-129 Inch Models
    09 mxz 500ss with only 1800 miles. Rode in jackman, me this past weekend. Sled was fine all day. Towards the end, shut it off for a few minutes on side of the trail and it gave me a no start. Both electric start and pull - nothing. It Would turn over. It had gas and compression. We checked for...
  13. MXZ / Legend / Summit / Grand Touring / Formula
    Hi everyone, I have been lurking on this forum for a day and a half, and found some good stuff. Unfortunately, not enough to get this newly acquired 2002 MXZ 700 Olympic Edition sled to run! Background: 52xx miles. Previous history unknown. It is a friends sled, he has had it for 3 years, and...
  14. MXZ / Legend / Summit / Grand Touring / Formula
    my 96 formula 500 wont start after i shut it off last night i was riding it for about 10 minutes shut it down to adjust the track and now it wont start. i have spark and compresion but dont thing im getting any fuel? can anyone help me with how the fuel system works? or have any ideas about the...
  15. Vintage Ski Doo's
    ok, so I am in the middle of a resotration and I have got to the point of starting the engine. This sled has sat in the barn for about 10-12 years and when I PERSONALLY put it away it ran. when I got it out this fall, I did not try to start it, just went into other resto stuff. I put the...
1-15 of 15 Results
Top