Ski-Doo Snowmobiles Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 54 Results
  1. MXZ / Legend / Summit / Grand Touring / Formula
    Yesterday after waiting weeks for snow finally got a chance to take my 2002 Mxz 800 out. Sled performed great did a few steep trails and a few flat trails and about 50 miles in total. Me and a buddy decided to stop for a bit but after our break I tried firing up the sled and it took around 6...
  2. MXZ / Legend / Summit / Grand Touring / Formula
    Sooo I fired my sled up to take a spin around my yard. Let it warm up in my garage for a few minutes while I’m getting my gear on the sled just shuts off. I try to start it get nothing at all!! So I check for spark an it has NONE. Where do I start an what do I replace first. Coil pack, stator...
  3. Mach Z / Mach 1 / Formula III Triples
    Hey all, I recently bought a 98 formula III 600 LT with relatively low KMs. I bought it knowing that it had No spark, but had good compression and was in really good shape. Reading previous posts, it seems like the 98' CK3 had plenty of problems associated with wiring, CDI, etc. It looks like...
  4. Vintage Ski Doo's
    I just bought a 1991 Formula MX that the previous owner bought as a barn find. He intended to get it running but never did. As far as I can tell it hasn't run since 1993, and only has 710 Km on it. So, today I started having a look at it, I took one carburetor off and I've never seen anything...
  5. MXZ / Legend / Summit / Grand Touring / Formula
    I know, another one of these threads... I've been at this on my own for months and this forum has been a blessing for answers that have very much helped me get to where I am, but now I'm at a loss and still facing the same issue as when I started. February 2021 the sled suddenly stops working...
  6. MXZ / Legend / Summit / Grand Touring / Formula
    I have a 96 700 GT SE i got last year. I bought it with an issue of fouling plugs within 15 min and hard start. Put it away for the summer and now its play time again. I put the battery charger on it in jump mode and it fired right up, but would die as soon as i pull the cables off. I thought...
  7. REV Chassis - Performance and Trail Models
    I bought a 05 rev mxz in july. It stated just fine and all was good. End of september i was installing new hood straps and i went to start it. No spark. I have taken apart the killswitch to clean the contacts and messed around with the dess switch. Anyone have any ideas as to what could be the...
  8. MXZ / Legend / Summit / Grand Touring / Formula
    hi Folks -we have a 2005 Skidoo Grand Touring 500 sled . She has been working perfectly for days. Half choke, push the start button, and she's fired up every single time. Today my wife took this machine out ice fishing. Everything was working perfectly - when she got to the fishing spot she...
  9. MXZ / Legend / Summit / Grand Touring / Formula
    1999 Ski Doo MXZ 600 roughly 3,500 miles (I have another matching sled to this one so I can swap parts) I need help friends! I've tried about everything I can think of and I'm going crazy. I'm fairly mechanically inclined but I'm really new to snowmobiles. Please help. SOS 12-31-2019 First...
  10. Freestyle / Legend / Tundra / Expedition Sport
    hi, i posted this problem in a different forum by mistake, so will try here. I have no spark on my 2015 tundra lt 550f. it started good last summer, but when i went to start it this winter, no spark at all. had dealer test cdi/coil and they said it was good. when i crank the engine, i'm getting...
  11. Skandic / Expedition
    Hi, new here so hopefully i'm doing this right? I have a 2015 Tundra 550 lt. it ran through the summer as i start it a few times through the off season. I tried starting it back in november, and nothing? machine has no spark? it's february now, and i finally have the time to work on it. I took...
  12. REV-XP/XS Chassis: Perf. Trail 120-129 Inch Models
    replaced stator and now no spark. had the crank position sensor hooked up bakwards as well for a while. all correct now but no spark. have done some testing and all seems good except for Capacitor not outputting 55 volts( around 38 v). Ecm? Thoughts? Thanks in advance
  13. REV-XP/XS Chassis: Renegades/Freeride/Backcountry
    replaced stator and now no spark. had the crank position sensor hooked up bakwards as well for a while. all correct now but no spark. have done some testing and all seems good except for Capacitor not outputting 55 volts( around 38 v) Ecm? Thoughts? Thanks in advance
  14. REV Chassis - Performance and Trail Models
    I just bought a non running sled with no spark. The top end was rebuilt with a 700. Supposably the original owner was riding it after rebuilt.now no spark when sold. What could this cause it to have no spark ? Coils ? Spark plugs ? Stator ? Mpem? Need some advice how to test it. Thanks guys
  15. Vintage Ski Doo's
    1994 Safari Dexuxe .....lost spark....motor is out and I have replaced CDI/Coil.....still nothin....does anyone know the proper ohm resistance for the trigger coil? The 1991 manual i have says 50 - 100.....I am showing 150 but i am not positive this spec is valid for a 1994. The ignition...
  16. Vintage Ski Doo's
    1994 Safari Dexuxe .....lost spark....motor is out and I have replaced CDI/Coil.....still nothin....does anyone know the proper ohm resistance for the trigger coil? The 1991 manual i have says 50 - 100.....I am showing 150 but i am not positive this spec is valid for a 1994. The ignition...
  17. Vintage Ski Doo's
    1994 Safari Dexuxe .....lost spark....motor is out and I have replaced CDI/Coil.....still nothin....does anyone know the proper ohm resistance for the trigger coil? The 1991 manual i have says 50 - 100.....I am showing 150 but i am not positive this spec is valid for a 1994. The ignition...
  18. Vintage Ski Doo's
    Can anyone here help my diagnose a faulty stator? Mine seems to check out fine when tested with an OHM meter on the generator side but wont produce any light thru the lighting coil. Does the lighting coil have anything to do with igniting the generator? I had the sled running several times...
  19. Skandic / Expedition
    Hello, I need some help. I have a 05 ski doo expedition tuv v1000. I got this ski completely disassembled when purchased. I have rebuilt both cylinders, new chains, plugs and cam(bolts sheared off) . Manuel is very unclear about timing. I do know I need the crank locked in tdc as well as front...
  20. Vintage Ski Doo's
    I have a 1995, I have had it for 2 seasons, this will be 3rd, and have had no issues til this year. I tried starting it mid summer and it appeared to have no spark. I left alone as I didnt have time to mess with it until recently and I pulled off the CDI and coil. The coil had nothing so I...
1-20 of 54 Results
Top