Ski-Doo Snowmobiles Forum banner
electrical
1-20 of 110 Results
Advanced
  1. MXZ / Legend / Summit / Grand Touring / Formula
    Got a new 2020 Grand Touring at the beginning of winter. It gets pretty damn cold here and I haven't had many opportunities to ride. Only put a couple hundred kms on it so far. The other day, battery was dead, did a booster on it and it started no problem. After a warm up I took it out for 20...
  2. MXZ / Legend / Summit / Grand Touring / Formula
    Hello, just got back into sport..bad timing. machines runs well..suddenly stopped. was able to restart run then stop 5 min to 1.5 hrs at a time then won't start What should I check battery i noticed loose connection, but recharged reinstalled no difference wont turn over. DESS?? CDI??
  3. MXZ / Legend / Summit / Grand Touring / Formula
    Hello, I have a 1996 Touring E 380 with electric start that cranks over nicely, starts with the key in the run position and by pulling the cord, but wont start by cranking it over. I have seen a number of discussions on here with similar year and model sleds where it was determined to be a...
  4. MXZ / Legend / Summit / Grand Touring / Formula
    My stock hand warmers melted the grips right around the same time all my lights conked out-- head, tail, and instrument. I installed a new voltage regulator and now the lights are fine (new bulbs of course), but the warmers don't warm. I assume they are cooked, just like the bulbs-- unless...
  5. MXZ / Legend / Summit / Grand Touring / Formula
    I replaced my voltage regulator, and now it's time to replace all the bulbs that blew due to the bad, old VR. Any advice on pushing the new speedo backlight bulbs into their sockets? Pushing with my bare hands isn't working-- I feel like the bulb will break. I'm sure there's a fancy tool out...
  6. Skandic / Expedition
    I have a 2003 Skandic 500F, I primarily use it for grooming trails a few times a year. At the start of last year my battery went bad so I replaced it and it still would not start with the starter (pull started fine). I checked the starter and it did not seem to be getting power, so this week I...
  7. Skandic / Expedition
    Has anybody come across one of these yet? Took the plunge to order a 2021 Expedition SWT 900ACE and would like to figure out how to add a few items ahead of time. Will be ordering the service manual soon but figured I'd ask about the wiring diagram first.
  8. General Discussion
    I have a 2003 Grand Touring 500 that mechanically, works great! I am, however, having a hell of a time with electrical issues. 1. My handlebar warmers and thumb warmer do not work. 2. Mechanically, the brakes work fine, but my Brake light is stuck in the "ON" position 3. Kill Switch works...
  9. MXZ / Legend / Summit / Grand Touring / Formula
    Not getting any traction in another sub, so I'll try here in general. I've wanted to update my sled's lights for the sake of safety and visibility. The LED-H4 headlight works, but the brightness is definitely affected by the RPM. But it works. As for the LED-1157 in the tail light, it'll work...
  10. REV-XR/XS Chassis: 4-TEC 1200 Perf. & Trail Models
    Noticed today during my ride, half the cluster isn't lit. Fuse or inside the cluster itself?
  11. REV-XP / XM Chassis - Mountain Sleds
    So I have a burned headlight, no big deal right? I thought so too. I go to changed it out, and discover that the female plug portion that plugs to the light bulb itself is partially melted and burned. Now the issue is? How do I go about changing that short of buy a whole new harness assembly...
  12. REV-XP/XS Chassis: Perf. Trail 120-129 Inch Models
    I've got a 2009 GSX with a 600 ETEC. During the last ride, I was riding down the trails and the sled stalled after a "FAIL REV" and "ECU" message flashed on the premium gauge. Afterwards, the sled would stall if both handlebar warmers and thumb warmers were turned up all the way. I checked...
  13. Mach Z RT and MXZ 1000 SDI Models
    Can anyone please tell me how many chassis grounds there are on the '05 1000 SDI wire harness; and where they are located? My sled is completely dead and I don't know where else to start. I have a brand new battery. All of my fuses and relays are in good working condition. When I put the Dess...
  14. REV-XP/XS Chassis: Renegades/Freeride/Backcountry
    Need some help! Last spring when I put my 2011 Rev XP 800 etec Renegade away, I used the summarization feature, removed the belt, put on my battery maintainer and put it on the stand. I rebuilt the primary clutch, put new hyfax on, couple idler wheels during the summer. Winter is nearing so I...
  15. Skandic / Expedition
    I know this has been discussed quite a bit on here but I'm looking for some clarification. I've been having intermittent starting issues with my sled. It starts with the solenoid clicking a couple of times but then starting and progresses to clicking and not starting. I put a new battery in back...
  16. REV Chassis - Performance and Trail Models
    So this has become a headache. My sled (2005 skidoo mxz renegade 600 HO SDI) stopped charging about the same time my dash lights stopped going off when the sled shut off. Some dummy lights came on in the dash also. Started to tear into it and found the ground on the voltage regulator was broke...
  17. MXZX Race Sleds
    I have a 2007 mxzx 440 that has been going back and forth from running perfect to bogging at all times. I recently had a bogging issue and discovered it was only running rich. So, I raised the main needle to the highest position (it was on the 2 from the top) and after that it ran like a champ...
  18. MXZ / Legend / Summit / Grand Touring / Formula
    Okay guys so I have a 2004 600 SDI and along with a possible gasket leak which I have another post going for...I was out last week on a run with the boys to diner and its about a 90km run round trip, about 3/4 the way back I couldn't rev over 6,500 and my engine light was on, when I got home I...
  19. Mach Z / Mach 1 / Formula III Triples
    Hi Guys, I'm rebuilding a 1998 Grand Touring SE 700 Triple. Here's the question. Why does the gauge cluster, including the tachometer, shut off when I try to pump up the rear shock? Is the compressor shorting out? Too much draw? It does pump up and register on the gauge once I let go of the...
  20. MXZ / Legend / Summit / Grand Touring / Formula
    My V-1000 blows the 30 amp fuse occasionally and lately it has stopped beeping when started or shut down. Wondering what might be causing these problems. The sled seems to be working fine right now but used to beep a couple times when started which was normal I think. As for the fuse it seems to...
1-20 of 110 Results
Top