Ski-Doo Snowmobiles Forum banner
bogging
1-20 of 34 Results
  1. REV-XP/XS Chassis: Perf. Trail 120-129 Inch Models
    Hi guys, I need some help with an issue my sled is having. Its a 2009 MXZ 600 etec with almost 20,000km and about 1000km on a full rebuild. First ride of the season on Thursday and about 10 minutes in of rail bed ridding (at a good speed) I feel a brief loss of power but it goes away. 5-10...
  2. MXZ / Legend / Summit / Grand Touring / Formula
    Ladies and Gents, more help needed! Working with a 1998 Formula 500 Deluxe. 4950 miles on it. I've owned it for 3 years. First time off the trailer was two days ago. Prior to un-trailering, I had started the engine on the trailer and the engine ran fine. Primes and starts well with electric...
  3. REV-XP/XS Chassis: Perf. Trail 120-129 Inch Models
    My 2015 MXZ has 2100 miles on it. During my last trip last year, i noticed that the engine would bog once I got up to a 3/4 to full throttle. I could cruise at about 65-70 mph, any throttle to speed up after that, it would bog back down. I started taking my sled apart this month. I found a lot...
  4. MXZX Race Sleds
    I have a 2007 mxzx 440 that has been going back and forth from running perfect to bogging at all times. I recently had a bogging issue and discovered it was only running rich. So, I raised the main needle to the highest position (it was on the 2 from the top) and after that it ran like a champ...
  5. REV-XP / XM Chassis - Mountain Sleds
    Just bought this sled from a guy in Iowa. It ran perfect for the first 100 miles or so and on my last run back to the truck it started acting up. At WOT it sounds like it's down a cyl or the computer is preventing it from running full power for some reason. A few things I've read say could be...
  6. MXZX Race Sleds
    So, last weekend I went on a snowmobile trip up north about 4 hours away from where I live. First day was great! Sled ran and started up fine. Second day got ready to head out again started up my sled for a few minutes filled it up with premium gas mixed with amzoil at 33:1. Same mix, fuel, and...
  7. REV-XP / XM Chassis - Mountain Sleds
    Hey guys, I have a 2013 Skidoo Summit Sport 600, 10300km and while I was taking my carb apart this is how my reeds were looking like (first picture clutch side, second is chaincase side). Last year my sled would start bogging if only I would crack the throttle from nothing to full throttle for...
  8. REV-XP/XS Chassis: Perf. Trail 120-129 Inch Models
    Cant solve this crazy problem, 2008 600 SDI with about 7000k on it just starred acting up last trip sled bogs and drops power from after 2-3 min of driving. You loose power until it wont move on the trail. Then you turn it off and start it up again and Immediatly it will stand up and dance...
  9. Skandic / Expedition
    Have some troubles with a 600 SDI. It has got 4300 km's on it. I have been searching around the forum without any luck so i start a new thread. It has been idling a little rough this and last season, especially until the engine temp comes up. The dealer has not been able to fix it entirely...
  10. REV-XP / XM Chassis - Mountain Sleds
    First ride on my new 15 summit x 146 last weekend with only 450mi. I get on the trail and it seemed to be running fine but i noticed there was a dead spot at about 7,000rpms. I kept riding it and it was spitting and sputtering once in the power band. It kept doing this for about 3-5 mi down the...
  11. REV-XP/XS Chassis: Renegades/Freeride/Backcountry
    2008 Renagade 600sdi bogging out... seems to be okay after engine shutdown and restart.. Even switching kill switch off and right back on before engine shuts off make it okay again for a klm er so
  12. REV-XP/XS Chassis: Renegades/Freeride/Backcountry
    Im having issues with my 2012 Renegade backcountry, Everything was fine, then we had freezing rain and it was left out for a minimum amount of time until i got home and covered it over. The next day I brought it inside a non heated garage, to get it ready to go for a ride the next day, had no...
  13. REV-XP/XS Chassis: Perf. Trail 120-129 Inch Models
    Is anyone having any issues with their 600 etec's bogging after a cold start? Runs like a champ after its warmed up and is showing no engine codes.
  14. REV-XP/XS Chassis: Renegades/Freeride/Backcountry
    Hey guys Iam having a problem with my 2012 skidoo renegade 600 etec. Sled has worked great up until I had to replace the stator at around 8000 km with a second hand Skidoo stator. After getting it running again I have put a solid 500km on the sled running it hard but noticed over the past little...
  15. REV-XR/XS Chassis: 4-TEC 1200 Perf. & Trail Models
    Just replaced the rollers and spring in my secondary clutch on my 2010 MxZ 1200 TNT about a week ago in my buddy's garage and it has sat there for two weeks since I've drove it last. The last time I was out with it, it was running perfectly fine ( other than driving it home with a swallowed belt...
  16. REV Chassis - Performance and Trail Models
    I went out on the first run of the year couple nights ago, the weather was kinda warm. after about 10 kms down the trail, the sled started to act a little funny, it started to bog down after 7000RPM, looked at my temp gauge, it was a little high but nothing to be alarmed over, so i stopped let...
  17. MXZ / Legend / Summit / Grand Touring / Formula
    Hey guys, New to the forum but have looked on here a few times and figured i'd join. So heres my problem or problems. Sorry for the long post but i like to be as detailed as possible. i have a 1996 formula S 380 that was originally my fathers since 96' he hasn't had it running for about 3...
  18. REV-XP / XM Chassis - Mountain Sleds
    Anyone experienced this or have any suggestions? After 30-45 seconds wide open on hill climbs, my engine loses power quickly and dies. If I'm in a committed steep hill climb spot, it's scary. If I immediately turn back downhill, it recovers and runs fine until the next climb after being...
  19. Freestyle / Legend / Tundra / Expedition Sport
    I have been working on fixing up a 97 T2. I have it all together now and took it on the maiden voyage. Well tried to!! After you warm it up on the trail, it bogs right out and if you let it sit and cool, away you go again. Issue Summary and What i have done: - Idles low even if you adjust...
  20. Vintage Ski Doo's
    Hey all, I bought my first ski doo the other day and it's in really great shape for bein 25 years old now. Unfortunately since the day I bought it I've been having an issue where it won't rev past 6000 rpm. Sometimes it will rev up quickly and go to full rpm (7000+) but more often than not it...
1-20 of 34 Results
Top