Ski-Doo Snowmobiles Forum banner
backfire
1-15 of 15 Results
  1. REV Chassis - Performance and Trail Models
    Hi I have a 2005 Ski Doo SDI 600 it has been backfiring a lot. I always hear people say the sdi's are known to do this. I am running br8ecs plugs and the plugs are definitely fouled, should I change to br9ecs plugs? I've checked in take boots they look fine no cracks. The sled idles fine but...
  2. REV Chassis - Performance and Trail Models
    I've got an 03 Rev 600HO that I had removed the engine to replace the crank seals (one popped out) Well anyway, I got it together and if I start it without the airbox on it runs and idles great but once I put the air box on it will start hard and when it does its like running on one cylinder and...
  3. REV-XP/XS Chassis: Perf. Trail 120-129 Inch Models
    Posting for a friend. 2015 mxz x-rs 600 etex. Bogg/delay when first taking off then takes off fine. Barely moves during warm up. Intermittent misfire/pop around 1/4 throttle only. 4300 miles on chassis About 400 on new motor. Motor still has warranty from dealer that rebuilt it.
  4. REV-XP/XS Chassis: Renegades/Freeride/Backcountry
    Help, 2011 600 etc, pull start only Ran rough, changed plugs at 11,000km. Ran perfect for 200k and started rough again, almost as if one one cylinder. Both plugs look black and dirty once out, will not idle but will keep running if held at 2500 rpm. Replaced fuel pump strainer just because...
  5. REV-XP/XS Chassis: Renegades/Freeride/Backcountry
    hey there! I happen to have a real problem on my 2010 renegade 800r ptek. the problem is that the sled seems to miss some spark on one cylinder(clutch side). When I go WOT chek engine comes ON and after a scan at BRP its the knock sensor. When I put it in reverse, the problem is worse. Its hard...
  6. REV Chassis - Performance and Trail Models
    hello. i just picked up a 2006 600sdi with a fresh motor. on cold start and up to operating temperature the sled backfires and hesitates on acceleration. seems ok after motor is @ 100 f. checked coolant and air temp sensors and all read proper ohms for temp. fuel pressure is @58 psi and battery...
  7. REV Chassis - Performance and Trail Models
    I have just rebuilt my 2003 skidoo rev 600 HO 3 days ago ( 140 psi both sides ) and i went to do my 3rd heat cycle and its been running like (excuse my language) complete $&@$ Its been backfiring on start up and it idles very low but i hear the 2 beeps on start up. I tried starting it again and...
  8. REV-XP/XS Chassis: Renegades/Freeride/Backcountry
    Hey guys. I'm having an issue with my buddies 2010 renegade 800 crap-tek. I'm posting it here because you guys just know the most about motors. It has around 3000km on it. Last Saturday we went for a big group ride. he did a cat walk (wheelie) and he said after it came back down it never ran...
  9. Mach Z RT and MXZ 1000 SDI Models
    Hey guys. I'm having an issue with my buddies 2010 renegade 800 crap-tek. I'm posting it here because you guys just know the most about motors. It has around 3000km on it. Last Saturday we went for a big group ride. he did a cat walk (wheelie) and he said after it came back down it never ran...
  10. Race Sled Classifieds
    I have a ski doo 440/800 mod and when I pull it over it backfires and it takes over 10 pulls to get it to start. I don't know what's going on. It also has a new top end so it has lots of compression. Jetting? Reeds? Something?
  11. REV Chassis - Mountain Sleds
    Hey Guys, New to snowmobiling this year. Bought a 2005 Summit 800 with roughly 2500 miles on it and loving it so far! However, I took it out last friday and it was running just fine. Went to start it up sunday morning, started fine. Started it again sunday afternoon but i snapped the choke...
  12. MXZX Race Sleds
    ok so i noticed yesterday my rs didn't seem to have the power it used too, wouldn't even idle for very long. on the way back from the ride i also ran it dry which didn't help. now today had a little trouble starting it and after about 15 minutes of ride i shut it off then all i got was...
  13. MXZ / Legend / Summit / Grand Touring / Formula
    i have a Formula z 583 r.a.v.e. and it will not stay running with out backfiring and stalling. it ran fine when i had it in garage. motor was rebuilt n has newer looking carbs. i have cleaned carbs, put clean gas in it, checked gas flow its fine, bought new plugs (which fowl out every time, very...
  14. MXZ / Legend / Summit / Grand Touring / Formula
    i have a Formula z 583 r.a.v.e. and it will not stay running with out backfiring and stalling. it ran fine when i had it in garage. motor was rebuilt n has newer looking carbs. i have cleaned carbs, put clean gas in it, checked gas flow its fine, bought new plugs (which fowl out every time, very...
  15. REV-XP / XM Chassis - Mountain Sleds
    i have looked all over the internet and havent really found anything with the symptoms i am having on my sled. hopefully someone here as had an issue like this and can get me running again...... i have a 2009 xp 800 everest. i took her out of hibernation the other day and decided to take...
1-15 of 15 Results
Top