Ski-Doo Snowmobiles Forum banner
600 e-tec
1-8 of 8 Results
  1. Sled Parts For Sale or Trade
    For Sale: 2011 Shop Manual for Rev XP, 800R power Tek, 600-800 E-Tec. Excellent condition, except for a few smudge marks here and there. $85.00 shipped
  2. REV-XP/XS Chassis: Renegades/Freeride/Backcountry
    I'm asking this question for my buddy who isn't on the forums. He has a '09 GSX, 600 E-TEC. It starts and runs well for a while, then drops a cylinder and starts running on one. The check engine light comes on and I assume it goes into limp mode. If you stop and shut it down for 5 minutes, it...
  3. REV-XP/XS Chassis: Renegades/Freeride/Backcountry
    Hey, Martin from Norway here :smile_old: I ride a lynx re 600 e-tec 2009, correct me if im wrong, but it should basicly be the same sled as the skidoo mxz Im thinking of doing some changes on my sled, like an extension package (120" - 137") from tracks usa, anyone bought from them? Also I...
  4. Skandic / Expedition
    Got my primary off for a cleaning can anybody tell me the torque specs for the bolt? Thanks sled is a 2013 expo 600 e-tec
  5. REV-XP/XS Chassis: Renegades/Freeride/Backcountry
    Hi I live in a small town in the southwest corner of Manitoba and I was going to buy a 2010 renegade backcountry 800 p-tek with the money i make over the summer only theirs one problem... where i live there is only a co-op that sells only 81 with 10-30% ethanol and i was running my 580 indy on...
  6. REV-XP/XS Chassis: Renegades/Freeride/Backcountry
    What is the quietest can out there? Looking for weight loss but keep stock sound or even quieter. 600 e-tec
  7. Skandic / Expedition
    Anybody put a trail can (silencer) on thier expo\skandic to lose a little front end weight? Something with a stock sound would be nice. Should lose 15-20 pounds.
  8. REV-XP/XS Chassis: Perf. Trail 120-129 Inch Models
    hello, my 600 e-tec seems to run perfectly fine when i first start it and ride for five six miles than it dies down to what seems to be one cylinder and barely runs but when i shut it off and start it back up it runs perfect again i think its possibly a computer problem but im completely lost on...
1-8 of 8 Results
Top