please help me!! ski-doo 440 running like "edit for bad l - MXZX Race Sleds - DOOTalk Forums

Jump to content

 






Photo

please help me!! ski-doo 440 running like "edit for bad l

440 race trail engine help can notrunningright

  • Please log in to reply
34 replies to this topic

#1 keewatin440

keewatin440

    Advanced Member

  • Members
  • PipPipPip
  • 37 posts
  • Gender:Male
  • Location:keewatin ont
  • Interests:sledding and hockey go check out brbproductons on instagram give em a follow!
  • Sled:2007 ski-doo mxz 440

Posted 22 December 2014 - 10:26 PM

anyone please help!! my sled as been getting fixed for about a month tonight was finaly the time i got to take it home! the guy who fixed it really know his race sleds and has had 2 07 440 same as mine.. i bought my sled out of brandon manitoba, was told it was a 2007 rev 440, it was raced but trail converted... that was a lie it had race heads and the hole 9 yards... it has a crack in the bulk head.. and had race heads...  everythng needed for racing.. i got f**** over.. really sucks.. as ive always wanted a 440 but back to my point , as i got my sled out of the truck and started it it idles really good!!! but once i give her gas it dosnt move and just crackles... my lights dont work nore does my tack... the guyt i have working on it his kid thinks the sled may have been sunk.. please someone help me!! i have finaly got a 440 and its the edit for bad language  :sad_old:  if you know anything or know how to fix it please help me!!!! 


BRB productions gheck it out on instagram, twitter & youtube 

 

sled :

07 440 

1.75 track

6 inch riser

c&a xt skis

j&t race can :wub:

 

 


#2 npickle12

npickle12

    Advanced Member

  • Members
  • PipPipPip
  • 2329 posts
  • Gender:Male
  • Sled:2018 XRS 850, 2009 770 RS

Posted 23 December 2014 - 09:38 AM

What do you mean it crackles?

Here's just a quick piece of advice and please don't take it the wrong way. But race sleds are somewhat finicky and you need to either learn about how they work so you can do all the work yourself. Or you have to pay someone to work on it.

If I were you, I would give it right back to the guy that's fixing it for you and show him the problem. If you can't work on it yourself, tell him that you don't want it back until it runs and drives correctly. My guess is that you have a carburetor issue...anyone that's owned and wrenched on a race sled should at least be able to get it running and driving. Otherwise find a new mechanic!

Are the low comp domes installed now? What fuel are you running? Has your buddy rejetted the sled to run properly with the low comp domes?

Edited by npickle12, 23 December 2014 - 09:39 AM.


#3 YellowMagic

YellowMagic

    Advanced Member

  • Members
  • PipPipPip
  • 213 posts
  • Gender:Male
  • Location:MI
  • Sled:2009 RS 600

Posted 23 December 2014 - 12:18 PM

Is the tether connected, lmao Idk I've seen people that just got there rev and the tethers have to be wiggled or it won't go anywhere

#4 bdth9447

bdth9447

    Advanced Member

  • Members
  • PipPipPip
  • 302 posts
  • Gender:Male
  • Location:Upstate Ny
  • Sled:2010 MXZ X-RS 800 sold :( 2007 440x

Posted 23 December 2014 - 05:07 PM

bad relay 



#5 fintastic

fintastic

    Advanced Member

  • Members
  • PipPipPip
  • 255 posts
  • Gender:Male
  • Location:Welch
  • Sled:2016 renagade 1200 X

Posted 23 December 2014 - 06:15 PM

I had a similar problem with my 03 and it ended up being cracked reeds

#6 keewatin440

keewatin440

    Advanced Member

  • Members
  • PipPipPip
  • 37 posts
  • Gender:Male
  • Location:keewatin ont
  • Interests:sledding and hockey go check out brbproductons on instagram give em a follow!
  • Sled:2007 ski-doo mxz 440

Posted 23 December 2014 - 06:43 PM

What do you mean it crackles?

Here's just a quick piece of advice and please don't take it the wrong way. But race sleds are somewhat finicky and you need to either learn about how they work so you can do all the work yourself. Or you have to pay someone to work on it.

If I were you, I would give it right back to the guy that's fixing it for you and show him the problem. If you can't work on it yourself, tell him that you don't want it back until it runs and drives correctly. My guess is that you have a carburetor issue...anyone that's owned and wrenched on a race sled should at least be able to get it running and driving. Otherwise find a new mechanic!

Are the low comp domes installed now? What fuel are you running? Has your buddy rejetted the sled to run properly with the low comp domes?

im running 330 main jet, trail needles, trail clutch weights, i know most my stuff about the 440! and once you hit 5000 rpm it losses power


BRB productions gheck it out on instagram, twitter & youtube 

 

sled :

07 440 

1.75 track

6 inch riser

c&a xt skis

j&t race can :wub:

 

 


#7 keewatin440

keewatin440

    Advanced Member

  • Members
  • PipPipPip
  • 37 posts
  • Gender:Male
  • Location:keewatin ont
  • Interests:sledding and hockey go check out brbproductons on instagram give em a follow!
  • Sled:2007 ski-doo mxz 440

Posted 23 December 2014 - 06:46 PM

bad relay 

so get a new relay?


BRB productions gheck it out on instagram, twitter & youtube 

 

sled :

07 440 

1.75 track

6 inch riser

c&a xt skis

j&t race can :wub:

 

 


#8 keewatin440

keewatin440

    Advanced Member

  • Members
  • PipPipPip
  • 37 posts
  • Gender:Male
  • Location:keewatin ont
  • Interests:sledding and hockey go check out brbproductons on instagram give em a follow!
  • Sled:2007 ski-doo mxz 440

Posted 23 December 2014 - 06:46 PM

Is the tether connected, lmao Idk I've seen people that just got there rev and the tethers have to be wiggled or it won't go anywhere

thats what i thought to but wheni tried wiggling it it still ran like crap


BRB productions gheck it out on instagram, twitter & youtube 

 

sled :

07 440 

1.75 track

6 inch riser

c&a xt skis

j&t race can :wub:

 

 


#9 keewatin440

keewatin440

    Advanced Member

  • Members
  • PipPipPip
  • 37 posts
  • Gender:Male
  • Location:keewatin ont
  • Interests:sledding and hockey go check out brbproductons on instagram give em a follow!
  • Sled:2007 ski-doo mxz 440

Posted 23 December 2014 - 06:49 PM

I had a similar problem with my 03 and it ended up being cracked reeds

thats what i think it is but wasnt sure 


BRB productions gheck it out on instagram, twitter & youtube 

 

sled :

07 440 

1.75 track

6 inch riser

c&a xt skis

j&t race can :wub:

 

 


#10 keewatin440

keewatin440

    Advanced Member

  • Members
  • PipPipPip
  • 37 posts
  • Gender:Male
  • Location:keewatin ont
  • Interests:sledding and hockey go check out brbproductons on instagram give em a follow!
  • Sled:2007 ski-doo mxz 440

Posted 23 December 2014 - 06:51 PM

I had a similar problem with my 03 and it ended up being cracked reeds

did your 03 idle bad with cracked reeds? becuase mine idles perfect just dosnt have no power past 5500 rpm


Edited by keewatin440, 23 December 2014 - 06:51 PM.

BRB productions gheck it out on instagram, twitter & youtube 

 

sled :

07 440 

1.75 track

6 inch riser

c&a xt skis

j&t race can :wub:

 

 


#11 keewatin440

keewatin440

    Advanced Member

  • Members
  • PipPipPip
  • 37 posts
  • Gender:Male
  • Location:keewatin ont
  • Interests:sledding and hockey go check out brbproductons on instagram give em a follow!
  • Sled:2007 ski-doo mxz 440

Posted 25 December 2014 - 03:41 PM

could it be my timing?


BRB productions gheck it out on instagram, twitter & youtube 

 

sled :

07 440 

1.75 track

6 inch riser

c&a xt skis

j&t race can :wub:

 

 


#12 440zed

440zed

    Member

  • Members
  • PipPip
  • 27 posts
  • Sled:2003 mxz 440x

Posted 27 December 2014 - 02:11 AM

What rpm is it idling at?

#13 keewatin440

keewatin440

    Advanced Member

  • Members
  • PipPipPip
  • 37 posts
  • Gender:Male
  • Location:keewatin ont
  • Interests:sledding and hockey go check out brbproductons on instagram give em a follow!
  • Sled:2007 ski-doo mxz 440

Posted 27 December 2014 - 07:10 PM

What rpm is it idling at?

it idles between 1500 and 2000 no problems at idle but once i hit 5000 my sled has no power... the track will spin but my rpm will just make it to 6000.. 


BRB productions gheck it out on instagram, twitter & youtube 

 

sled :

07 440 

1.75 track

6 inch riser

c&a xt skis

j&t race can :wub:

 

 


#14 Braaap94

Braaap94

    Advanced Member

  • Members
  • PipPipPip
  • 112 posts
  • Gender:Male
  • Sled:2003 ski doo MXZ-X 440

Posted 27 December 2014 - 07:24 PM

My 03 440 is doing the same but I have the wrong clutches on it. Got a new set coming for it so hopefully that will fix my rpm issue.

Edited by Braaap94, 27 December 2014 - 07:24 PM.

1984 Bravo 250

1998 Formula Deluxe 583

2003 MXZ 440X Race 

2008 Arctic Cat F6 LXR

 


#15 hemi_newman

hemi_newman

    Advanced Member

  • Members
  • PipPipPip
  • 562 posts
  • Gender:Male
  • Location:Hayward,WI
  • Interests:Machinist
    Vol.Firefighter
  • Sled:2005 MXZX 440

Posted 27 December 2014 - 10:46 PM

it idles between 1500 and 2000 no problems at idle but once i hit 5000 my sled has no power... the track will spin but my rpm will just make it to 6000.. 

I would go though your clutches,sounds like a clutch issue to me.







Also tagged with one or more of these keywords: 440, race, trail, engine, help, can, notrunningright

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users