2014 - 800 Etec Recall - Page 7 - Ontario - DOOTalk Forums

Jump to content

 






Photo

2014 - 800 Etec Recall

reed recall valve etec 800 800R 2014

  • Please log in to reply
92 replies to this topic

#91 6KJR

6KJR

    Advanced Member

  • Members
  • PipPipPip
  • 11224 posts
  • Gender:Male
  • Location:Belleville ON
  • Sled:2014 Renegade

Posted 30 December 2014 - 05:28 PM

I don't see any dots on that location. Read the bulletin again and I see no dot no further action required so I should be good to go.

 

 

Excellent!

 

 

 

 

BRP just called me and told me about the Recall???

 

 

Hey at least you got a phone call.

Read up on this thread..



#92 dustydoo

dustydoo

    Member

  • Members
  • PipPip
  • 10 posts
  • Gender:Male
  • Sled:2014sp xm 154

Posted 01 February 2015 - 12:39 AM

my sled is a 2014 sp 154 bought December 30th 2013.   At 1768 km the cel light came on after the sled was running rough and back firing,  before it did this it wouldn't rev over 6000 rpm.   the code 1477 was displayed which is rave valve not closed.   i took it to the dealer and he claims he found a disconnected hose and that was my problem.   Today i took it out and it did it again.  Ran good for a half hour then wouldn't go over 6000 rpm, started back firing and displayed 1477 cel code.   got it back to blue called the dealer at RTR and he wants me to take it back.   After finding this thread mine has no dots that i can see, but has number 409, im gonna assume that my raves are toast, and demand the recall.



#93 MTNsleder

MTNsleder

    Member

  • Members
  • PipPip
  • 10 posts
  • Sled:2014 Summit x

Posted 19 February 2019 - 01:26 PM

Just booked my sled at the dealer today, getting my rave valves replaced on my 2014 summit under the recall at 5000 km. Sled was running like crap asked the dealer if there was a recall still on it because of this thread, thanks.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users