Fresh Rebuild, PTEK Backfire... - REV-XP / XM Chassis - Mountain Sleds - DOOTalk Forums

Jump to content

 






Photo

Fresh Rebuild, PTEK Backfire...

Summit PowerTEK PTEK Skidoo

  • Please log in to reply
6 replies to this topic

#1 BennyPTEK

BennyPTEK

    Newbie

  • Members
  • Pip
  • 3 posts
  • Sled:2013 Summit SP 800R PTEK

Posted 03 March 2021 - 10:03 AM

Hello, hoping someone has fixed something similar.

My 2013 Summit Sport PTEK blew up last year and burned a whole bunch of coolant. I did a crank exchange, replated the cylinders, replaced temp sensors and put a new dash in.

Now when I’m trying to start it up, it backfires when it gets over about 1500 RPM. I thought it might be the carbs so I took them off and cleaned them and still getting the same... will post a vid tonight. Has anyone had anything like this before?

Cheers

#2 Ski-B

Ski-B

    Advanced Member

  • Members
  • PipPipPip
  • 5891 posts
  • Gender:Male
  • Location:Saskatchewan
  • Sled:2020 Freeride 850

Posted 03 March 2021 - 08:09 PM

The two small trigger coils. It is easy to get them mixed up. If they are swapped around in there location. It won't start only backfire occasionally. 


2020 Freeride 850. My ride.

2018 XRS 850 Sons sled.

2017 Freeride 860R etec. 860BB. Daughters sled.

2015 Freeride 800R etec. All Stock. Wifes sled.

2015 BCX  800R etec. Trail ported. Spare sled.

2014 BCX 800R etec. All stock. Spare sled.

1998 Formula S 380. She is a keeper.


#3 BennyPTEK

BennyPTEK

    Newbie

  • Members
  • Pip
  • 3 posts
  • Sled:2013 Summit SP 800R PTEK

Posted 03 March 2021 - 09:20 PM

The two small trigger coils. It is easy to get them mixed up. If they are swapped around in there location. It won't start only backfire occasionally.


The round thing with two clips? I tried switching them once, the video is what it sounded like before. It sounds better now, I think I have the black on top and white on bottom.

#4 Ski-B

Ski-B

    Advanced Member

  • Members
  • PipPipPip
  • 5891 posts
  • Gender:Male
  • Location:Saskatchewan
  • Sled:2020 Freeride 850

Posted 05 March 2021 - 03:41 PM

Oh ok. I thought the trigger coils were green on top. Blue on bottom. If it is running perfect. Just drive her.

2020 Freeride 850. My ride.

2018 XRS 850 Sons sled.

2017 Freeride 860R etec. 860BB. Daughters sled.

2015 Freeride 800R etec. All Stock. Wifes sled.

2015 BCX  800R etec. Trail ported. Spare sled.

2014 BCX 800R etec. All stock. Spare sled.

1998 Formula S 380. She is a keeper.


#5 BennyPTEK

BennyPTEK

    Newbie

  • Members
  • Pip
  • 3 posts
  • Sled:2013 Summit SP 800R PTEK

Posted 28 March 2021 - 03:20 PM

My pickup coils are in the right place but it still has the backfire. Could it have anything to do with my stator wires? I didn’t have a removal tool to get the wires out of the clip so I cut and spliced them together again. Had to do this to get them through the round hole in the outside of the crankcase. I used some butt connectors and then shrink wrapped and taped them so I don’t think it’s messed I at all.

#6 Ski-B

Ski-B

    Advanced Member

  • Members
  • PipPipPip
  • 5891 posts
  • Gender:Male
  • Location:Saskatchewan
  • Sled:2020 Freeride 850

Posted 30 March 2021 - 10:27 AM

You say a new Dash? Did you replace the Gauge assembly in it as well? The gauge assembly has to be programmed to function correctly. Could be the gauge causing grief.

 

If it had spark and started fine before the engine work? Then yes the stator wire would be a good area to look into.


2020 Freeride 850. My ride.

2018 XRS 850 Sons sled.

2017 Freeride 860R etec. 860BB. Daughters sled.

2015 Freeride 800R etec. All Stock. Wifes sled.

2015 BCX  800R etec. Trail ported. Spare sled.

2014 BCX 800R etec. All stock. Spare sled.

1998 Formula S 380. She is a keeper.


#7 Daag44

Daag44

    Advanced Member

  • DOOCrew
  • 27670 posts
  • Gender:Male
  • Location:South Shore, Quebec
  • Interests:1973 Olympic
  • Sled:2007 1000 SDI

Posted 01 April 2021 - 08:50 PM

You say a new Dash? Did you replace the Gauge assembly in it as well? The gauge assembly has to be programmed to function correctly. Could be the gauge causing grief.

 

If it had spark and started fine before the engine work? Then yes the stator wire would be a good area to look into.

 
Have you seen the gauge ever cause strange issues? The weirdest case I have ever heard was an rpm gauge on an SDI preventing the engine from reaching max rpm. Just imagine how hard and how long you need to fight a low rpm issue to begin thinking of replacing the rpm gauge. It was over a calendar year with a rebuild and  many part swaps. I am still weirded out by that one.


Edited by Daag44, 01 April 2021 - 08:54 PM.

Air/Fuel Ratio for two and four strokes
Air/Fuel Ratio for 1200 with boost
Air/Fuel Ratio is measured through emissions
Wideband and EGT
Wideband readings of Air/Fuel Ratio on a two stroke
600 SDI MY2004 Lean/Hot spot running 6900-7000 rpm @ 40-45% Throttle Opening
800R Cranking Compression
800R Oil Injection / Premix combo
800R P-TEK Electrical Troubleshooting #1 and #2 
800R Turbo
850 Center Oil line for coolant pump melted
850 Main Oil line caught fire #1 and #2
900 ACE Turbo - muffler turning red hot
1200 4-TEC Mapping
1200 4-TEC MY 2009 to 2011 Fuel Line issues that could cause a fire
Batteries
Belt Blowers: Overview of UPMICHIGANDER's and Ronn's experience
BUDS 3.3.0 won't connect to SDI
BUDS not connecting to HO or SDI - Try a CanDoo
Crankshaft runout - maximum allowable specs 
CVT efficiency - BlueMax
Deep snow intake for XP chassis
Electrical - ECM drivers for Ignition Coils and E-TEC injectors 
Electrical - Diagnoses of a failed ECM
Electrical - 30A Battery Charging Fuse Socket Diagnoses and Relay
Electrical - Relay Coil Wine
Electrical - Relay Testing
Electrical - Battery Charging Relay Diagnostic 
Electrical - Troubleshooting with BRP video 
Electrical - Solder vs Crimp
Electrical - Diagram for Fanners on page 3
Engine Break-In 
Engine Weight 
E-TEC 600HO Clutching
E-TEC Oil Pump
E-TEC Dial-A-Jet
E-TEC Electric Start troubleshooting
E-TEC Engine Management
E-TEC eRAVE position code recurring
E-TEC Stator fault codes P1562 or P1563
E-TEC Capacitor Charge Hold Test and Residual Voltage Test
E-TEC Voltage Rectifier Regulator troubleshooting
E-TEC Power Fades are not normal and can be fixed
Fuel Issues: Could new Ester type oxygenated additives be deteriorating the Fuel Sender Grommet?
Fuel pump and regulator replacement for ACE, E-TEC and SDI
Gasoline quality and storage
Bad Gas for a Two Stroke - Is it a Myth ?
GNR CVT Alignment for the G4
Grip N Rip Clutch Alignment testing
G4 Clutch Alignment, Engine Movement, Sheave Runout and Clutching
G4 850 Throttle Jerkiness solved with clutching
G4 850 Snappy throttle/clutch engagement
G4 850 pDrive tech - A question of Engineering
G4 Steering
G4 850 Tuned Pipe @ 12.6 lbs and Muffler @ 15.4 lbs vs 800R and 800RE muffler weight
Longevity - 800R E-TEC 
Mikuni o-ring for carb float assembly - Arctic Cat part# 6505-875 or from Amazon and eBay
Muffler Red Hot
Off-trail riding for flatlanders
Oil versus Fuel consumption
Pictures - How to resize and upload to DooTalk
Pictures - How to post with the correct orientation
Pipe Pressure testing on a dyno
Pipe Pressure testing from LRD (#1) and (#2)
Pipe Pressure testing results from BRP
Power Loss - How to diagnose in the field
Power at the Crankshaft vs Track - BlueMax
Power Curves: 600 HOE (E-TEC)
Power Curves: 600 vs 800 vs 850 vs 1000 vs 1200
Power Curves: 1000 vs 800 vs 600
Power curves: 800RE 2010.5 to 2016 vs 2016.5 850
Quebec/NY State border crossing
REV Gen1 Gauge Display stuck on "SCALE"
REV Gen1 Volt and Temp Gauge install
REV Gen1 electrical connectors for sensors and MPEM (Multi Purpose Engine Module)
Seafoam for E-TEC injectors
Shortblock or Rebuild?
Ski-Doo Snowmobile Tech Training
Spark Plugs cracked
Squish - The limit
Squish - A discussion on head design
Stator and Relay Diagnostic 
Stator testing for E-TEC using a T harness/Bridge
Stator testing for 1200 4-TEC
Stator Removal on page 3
Stator replacement for a 1200 4-TEC
Suspension Adjustment
Triples - Coolant Pump Assembly
Y-Pipe bolts loosening fix






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users