Ugh lost the wave washer for the fuel filter - Skandic / Expedition - DOOTalk Forums

Jump to content

 






Photo

Ugh lost the wave washer for the fuel filter


  • Please log in to reply
13 replies to this topic

#1 badriverexpy

badriverexpy

    Advanced Member

  • Members
  • PipPipPip
  • 195 posts
  • Gender:Male
  • Location:SW AK
  • Sled:2016 Expadtion LE 900

Posted 26 February 2021 - 09:08 PM

Into the engine bay.

Had a towel to catch it and I heard a little tinkle.

Replaced the filter and orings yesterday and the outer oring leaked. Even though I was very careful putting it in.

So I pulled the cap off the filter to replace.

Have some on order and it will be 7-10 days before they get here.
Will be looking in the engine bay for the original.

I need a little person to look for it. Lol

#2 suv1

suv1

    Advanced Member

  • Members
  • PipPipPip
  • 6959 posts
  • Gender:Male
  • Location:Lower North Shore Quebec
  • Interests:Updated sled list!!!!
    2010 V800SWT
    2013 600aceSWT
    2014 600ACEWT
    2014 600aceSWT
    2016 900aceSWT
    2017 900aceSWT
    coming soon..
    2020 900aceLE
  • Sled:"16/900SWT/V800SWT600skandic600 ACEWT

Posted 27 February 2021 - 05:59 AM

Welcome to the club, i always keep a couple spare now!

with the muffler out and can't see feel around with a magnet taped to a stiff wire 


Updated sled list!!!!   ////2010 V800SWT

                               ////2013 600ACESWT

                               ////2014 600ACEWT

                               ////2016 900ACESWT

 

 


#3 badriverexpy

badriverexpy

    Advanced Member

  • Members
  • PipPipPip
  • 195 posts
  • Gender:Male
  • Location:SW AK
  • Sled:2016 Expadtion LE 900

Posted 27 February 2021 - 01:34 PM

Welcome to the club, i always keep a couple spare now!
with the muffler out and can't see feel around with a magnet taped to a stiff wire


Been trying but no luck so far.
I need to learn to not work on things when my hands don't work so well.

Supposedly every dealer in Alaska is out of the wave washer! Lol

#4 suv1

suv1

    Advanced Member

  • Members
  • PipPipPip
  • 6959 posts
  • Gender:Male
  • Location:Lower North Shore Quebec
  • Interests:Updated sled list!!!!
    2010 V800SWT
    2013 600aceSWT
    2014 600ACEWT
    2014 600aceSWT
    2016 900aceSWT
    2017 900aceSWT
    coming soon..
    2020 900aceLE
  • Sled:"16/900SWT/V800SWT600skandic600 ACEWT

Posted 27 February 2021 - 03:58 PM

You can make one temporary , take care not to block the return line that all


Updated sled list!!!!   ////2010 V800SWT

                               ////2013 600ACESWT

                               ////2014 600ACEWT

                               ////2016 900ACESWT

 

 


#5 badriverexpy

badriverexpy

    Advanced Member

  • Members
  • PipPipPip
  • 195 posts
  • Gender:Male
  • Location:SW AK
  • Sled:2016 Expadtion LE 900

Posted 27 February 2021 - 06:59 PM

Found the little bugger.
Had to use a .22 cleaning rod to get it out. Was wedged in on the a electric box.

Will try post up a pic of my middle spark plug. The coil likes to go out.


I hate working on stuff in the cold. 🤐

#6 slo_mo

slo_mo

    Advanced Member

  • Members
  • PipPipPip
  • 265 posts
  • Sled:Renegade ACE600

Posted 02 March 2021 - 06:29 AM

I found by using a magnet tool while removing the fuel filter and associated parts the screws, retaining metal pieces and the wave washer all stuck together for easier removal. I keep loosing the rubber o rings!



#7 suv1

suv1

    Advanced Member

  • Members
  • PipPipPip
  • 6959 posts
  • Gender:Male
  • Location:Lower North Shore Quebec
  • Interests:Updated sled list!!!!
    2010 V800SWT
    2013 600aceSWT
    2014 600ACEWT
    2014 600aceSWT
    2016 900aceSWT
    2017 900aceSWT
    coming soon..
    2020 900aceLE
  • Sled:"16/900SWT/V800SWT600skandic600 ACEWT

Posted 02 March 2021 - 08:22 AM

 I keep loosing the rubber o rings!

Ya you need to be careful with that one if changing just the paper filter with the pump on the sled


Updated sled list!!!!   ////2010 V800SWT

                               ////2013 600ACESWT

                               ////2014 600ACEWT

                               ////2016 900ACESWT

 

 


#8 badriverexpy

badriverexpy

    Advanced Member

  • Members
  • PipPipPip
  • 195 posts
  • Gender:Male
  • Location:SW AK
  • Sled:2016 Expadtion LE 900

Posted 12 April 2021 - 12:40 PM

Well had a weird start up on Friday.

It started up normally then it quit.
Would only run for a second then quit.
Had to hold the throttle open to get it to run like it was super cold but the temperature was in low 30'sf.
After a bit it finally ran correctly but with the same 50-100 rpm surge it has had for awhile.

I could here the pump build pressure.

All grounds have been cleaned.

#9 suv1

suv1

    Advanced Member

  • Members
  • PipPipPip
  • 6959 posts
  • Gender:Male
  • Location:Lower North Shore Quebec
  • Interests:Updated sled list!!!!
    2010 V800SWT
    2013 600aceSWT
    2014 600ACEWT
    2014 600aceSWT
    2016 900aceSWT
    2017 900aceSWT
    coming soon..
    2020 900aceLE
  • Sled:"16/900SWT/V800SWT600skandic600 ACEWT

Posted 12 April 2021 - 07:36 PM

Check the positive wire on the battery


Updated sled list!!!!   ////2010 V800SWT

                               ////2013 600ACESWT

                               ////2014 600ACEWT

                               ////2016 900ACESWT

 

 


#10 badriverexpy

badriverexpy

    Advanced Member

  • Members
  • PipPipPip
  • 195 posts
  • Gender:Male
  • Location:SW AK
  • Sled:2016 Expadtion LE 900

Posted 12 April 2021 - 08:48 PM

Check the positive wire on the battery

Nice and tight.

It started up good multiple times today but still has the 50-100 rpm drop/jump.
You can feel the vibrations in the handle bars and body. Windshield shakes too.

I threw some good injector cleaner in so we will see what happens.

#11 suv1

suv1

    Advanced Member

  • Members
  • PipPipPip
  • 6959 posts
  • Gender:Male
  • Location:Lower North Shore Quebec
  • Interests:Updated sled list!!!!
    2010 V800SWT
    2013 600aceSWT
    2014 600ACEWT
    2014 600aceSWT
    2016 900aceSWT
    2017 900aceSWT
    coming soon..
    2020 900aceLE
  • Sled:"16/900SWT/V800SWT600skandic600 ACEWT

Posted 13 April 2021 - 04:39 AM

Nice and tight.

It started up good multiple times today but still has the 50-100 rpm drop/jump.
You can feel the vibrations in the handle bars and body. Windshield shakes too.

I threw some good injector cleaner in so we will see what happens.

Check the head & taillight...normal steady beam or strobing?


Updated sled list!!!!   ////2010 V800SWT

                               ////2013 600ACESWT

                               ////2014 600ACEWT

                               ////2016 900ACESWT

 

 


#12 badriverexpy

badriverexpy

    Advanced Member

  • Members
  • PipPipPip
  • 195 posts
  • Gender:Male
  • Location:SW AK
  • Sled:2016 Expadtion LE 900

Posted 13 April 2021 - 11:45 AM

Check the head & taillight...normal steady beam or strobing?

All normal.
Will see if the dealer can read codes but the snow is disappearing very quick in town.
Makes me wonder if a injector is missing a bit.

#13 suv1

suv1

    Advanced Member

  • Members
  • PipPipPip
  • 6959 posts
  • Gender:Male
  • Location:Lower North Shore Quebec
  • Interests:Updated sled list!!!!
    2010 V800SWT
    2013 600aceSWT
    2014 600ACEWT
    2014 600aceSWT
    2016 900aceSWT
    2017 900aceSWT
    coming soon..
    2020 900aceLE
  • Sled:"16/900SWT/V800SWT600skandic600 ACEWT

Posted 13 April 2021 - 03:20 PM

Possibly injector or coil


Updated sled list!!!!   ////2010 V800SWT

                               ////2013 600ACESWT

                               ////2014 600ACEWT

                               ////2016 900ACESWT

 

 


#14 badriverexpy

badriverexpy

    Advanced Member

  • Members
  • PipPipPip
  • 195 posts
  • Gender:Male
  • Location:SW AK
  • Sled:2016 Expadtion LE 900

Posted 13 April 2021 - 06:46 PM

Possibly injector or coil

Just put three new coil and plugs in.

If I get warm weather without any rain/snow I may pull one.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users