550 fan engine problems - REV-XP / XS Chassis - Performance Trail 120-129 Inch Models - DOOTalk Forums

Jump to content

 






Photo

550 fan engine problems

engine 550F BRP

  • Please log in to reply
5 replies to this topic

#1 BRPDad

BRPDad

    Newbie

  • Members
  • Pip
  • 2 posts
  • Sled:2014 Renegade/2008 GTX

Posted 14 February 2021 - 08:46 AM

Hi, I'm totally new to this site...forgive me if this is not the right place to ask this. My son has a 2008 GTX 550F, the other day he lost the engine in it (piston and rings). I replaced the piston and rings and now the machine runs very rough and the entire engine is covered in oil. Anyone out there got any ideas as to what's causing the oil "spray" and where it could be coming from?



#2 stealth bomber

stealth bomber

    Advanced Member

  • Members
  • PipPipPip
  • 13542 posts
  • Gender:Male
  • Interests:Running over snowflakes
  • Sled:2020 XRS 850

Posted 14 February 2021 - 08:56 AM

Clean oil or black oil? Clean oil would be from the injection system, possibly a cracked line and the fan is blowing it around. Dirty oil most likely from the exhaust, the gaskets are kind of hard to keep in place with the fan shroud, one could have slipped out of place. Did you determine the cause of the failed piston? These engines are very reliable and unless the mileage is very high they don’t fail without an underlying condition.

#3 always ski-doo

always ski-doo

    Advanced Member

  • Members
  • PipPipPip
  • 123 posts
  • Gender:Male
  • Location:Newton New Jersey & Herrick Center PA
  • Sled:2020 600R T'NT

Posted 14 February 2021 - 09:01 AM

As previous,  It's likely the oil situation is related to the piston failure. Pisons look different from oil loss than burn downs, but i dont have any pics. it could be the other piston is damaged also. Look at Ski-doo parts page, 2006,mxz,   for how the oil line is run from the pump, likely a cracked  line. I cant seem to post the pic, but there re 2 different pages for the oil system. 


Edited by always ski-doo, 14 February 2021 - 09:06 AM.


#4 Ski-B

Ski-B

    Advanced Member

  • Members
  • PipPipPip
  • 5897 posts
  • Gender:Male
  • Location:Saskatchewan
  • Sled:2020 Freeride 850

Posted 14 February 2021 - 09:20 AM

Check your throttle cable it splits off with one cable going to the oil pump on the recoil side. Make sure the oil pump cable is not broken. Might be the reason for engine failure.  There is also a small white plastic drive gear in behind the oil pump. That little gear can strip the teeth and the oil pump has no drive.

 

Oil in engine compartment as mentioned could be exhaust gas. A secret to assembling engines with a Y pipe is. Install the cylinders but leave them loose. Next move onto the Y pipe. Install the y pipe and torque up to spec... then go back and torque up the cylinders and head. This way you get a nice flat seal on the Y pipe gskts and no leakage. Good Luck.


2020 Freeride 850. My ride.

2018 XRS 850 Sons sled.

2017 Freeride 860R etec. 860BB. Daughters sled.

2015 Freeride 800R etec. All Stock. Wifes sled.

2015 BCX  800R etec. Trail ported. Spare sled.

2014 BCX 800R etec. All stock. Spare sled.

1998 Formula S 380. She is a keeper.


#5 BRPDad

BRPDad

    Newbie

  • Members
  • Pip
  • 2 posts
  • Sled:2014 Renegade/2008 GTX

Posted 14 February 2021 - 09:37 AM

Thanks everyone! It's black oil, I've already checked the entire oil system, no cracked lines, pump is working fine...because it's black oil I knew it had already been through the engine. I also checked the Y-pipe, everything seems to be tight, however, it could be a broken exhaust gasket...I didn't even think about that!! Thanks again.



#6 SKIDOZER500

SKIDOZER500

    On Thin Ice with Steve

  • Members
  • PipPipPip
  • 35296 posts
  • Gender:Male
  • Location:Raymond/New Portland me
  • Sled:2016 tnt 900 ace 09 tnt500ss 05mxz 500ss

Posted 14 February 2021 - 06:12 PM

Maybe a loose spark plug?


Sent from my Taliban satellite phone

America,the home of the ENTITLED






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users