2017 MXZ 850 Hesitation - REV-GEN 4 - MXZ Performance Trail 129/ Renegade 137 - DOOTalk Forums

Jump to content

 






Photo

2017 MXZ 850 Hesitation


  • Please log in to reply
10 replies to this topic

#1 75rat

75rat

    Member

  • Members
  • PipPip
  • 14 posts
  • Sled:2017 MXZ X

Posted 06 February 2021 - 07:07 PM

Have a 2017 MXZ X 850 with a high speed hesitation. Sled is stock with about 4000 miles. Been riding for over 50 years and this is my first Ski Doo. Really like it, but this hesitation is kind of annoying.

Sled runs great and pulls strong up to 6500 rpm (about 60 mph). Give it a little more throttle and it takes off like a rocket and instantly gets over 7000 rpm. However, if you ease off the throttle slightly, it immediately drops to 6000 rpm. Almost feels like hitting the kill switch. Squeeze the throttle more and it takes right off again. It won’t run a steady 6500 rpm, it’s either 6200 or 7000.

Could it be a rave valve issue? Clutch?

Any help would be appreciated. Thanks

#2 AZSnowlvr

AZSnowlvr

    Advanced Member

  • Members
  • PipPipPip
  • 613 posts
  • Gender:Male
  • Location:48060
  • Interests:Previous Sleds
    2011 1200 X
    2004 Adr 800
  • Sled:2017 G4 850X

Posted 06 February 2021 - 07:08 PM

Start with plugs

Sent from my Pixel 5 using Tapatalk

#3 75rat

75rat

    Member

  • Members
  • PipPip
  • 14 posts
  • Sled:2017 MXZ X

Posted 06 February 2021 - 07:10 PM

New plugs and they are indexed. Also has a new fuel pump and fuel filter.

#4 AZSnowlvr

AZSnowlvr

    Advanced Member

  • Members
  • PipPipPip
  • 613 posts
  • Gender:Male
  • Location:48060
  • Interests:Previous Sleds
    2011 1200 X
    2004 Adr 800
  • Sled:2017 G4 850X

Posted 06 February 2021 - 07:14 PM

New plugs and they are indexed. Also has a new fuel pump and fuel filter.

Does it pull full RPM? I have also found a set of plugs that weren't gapped correctly

Sent from my Pixel 5 using Tapatalk

#5 75rat

75rat

    Member

  • Members
  • PipPip
  • 14 posts
  • Sled:2017 MXZ X

Posted 06 February 2021 - 09:48 PM

No problem getting over 100mph, so I assume it maxes out the rpms (don’t usually look at gauges at those speeds...lol)
If I squeeze the throttle aggressively from a dead stop, it pulls hard all the way past 100 without missing a beat.
If I apply throttle more slowly, it pulls hard and smooth up to 6500 rpm (about 65-70 mph), there is a definite hesitation then it pulls hard like a turbo kicks in. If I stop adding throttle (but don’t let up) rpms immediately drop to 5800-6000 rpm. Give a little more throttle and it jumps right back up over 7000 rpm.
Keep in mind, this only happens when the throttle is advanced slowly. Makes it difficult to keep a constant speed between 65 and 70mph.

#6 AZSnowlvr

AZSnowlvr

    Advanced Member

  • Members
  • PipPipPip
  • 613 posts
  • Gender:Male
  • Location:48060
  • Interests:Previous Sleds
    2011 1200 X
    2004 Adr 800
  • Sled:2017 G4 850X

Posted 06 February 2021 - 09:50 PM

Sounds like rave valves are sticking

Sent from my Pixel 5 using Tapatalk

#7 75rat

75rat

    Member

  • Members
  • PipPip
  • 14 posts
  • Sled:2017 MXZ X

Posted 06 February 2021 - 09:52 PM

Does it pull full RPM? I have also found a set of plugs that weren't gapped correctly
Sent from my Pixel 5 using Tapatalk

Yes, I did gap the plugs per the service manual.

#8 75rat

75rat

    Member

  • Members
  • PipPip
  • 14 posts
  • Sled:2017 MXZ X

Posted 06 February 2021 - 10:13 PM

Sounds like rave valves are sticking
Sent from my Pixel 5 using Tapatalk


That was my first thought, but being new to everything etec, I appreciate any advice I can get. Think I’ll be taking a look at the rave valves.
Thanks for all your help, this is a great site!

#9 Buzzyboy

Buzzyboy

    Newbie

  • Members
  • Pip
  • 3 posts
  • Gender:Male
  • Location:Nova Scotia
  • Sled:Mxzx850

Posted 19 February 2021 - 05:44 AM

Hi 75rat,

mine was doing the same until last weekend. Took the wife up to camp for long weekend of sledding. Towed bogging into camp(about 7 miles)no problem. Spent couple of hours getting wood stoves going to warm up camp. Decided to go for a quick rip after supper. Warmed up sled for five or so minutes. Ran fine for first mile,then sorta hesitated, made a weird noise then smoothed out, another half mile it does it again then dies. Wound up getting towed to truck. Took it to mechanic. At first he said plugs. They replaced plugs and it still would not start. Compression test showed none on one side, she’s toast. Looking at replacement motor. Likely 3 grand to fix. This machine ran fine except for the same issue you are experiencing. Not sure if that was reason or part of reason she died. Will post if/when I find out. 
Buzzyboy



#10 75rat

75rat

    Member

  • Members
  • PipPip
  • 14 posts
  • Sled:2017 MXZ X

Posted 23 February 2021 - 12:19 PM

Thanks for your feedback buzzy,
Bummer, hopefully I won’t have those problems.
Been riding steady for the last few weeks with many 100+ mile days and had no issues. Runs great except for the annoying hesitation when transitioning 6500 rpm. Plan on going through rave valve once riding season is over. Hopefully that will take care of it. 75rat

#11 Daag44

Daag44

    Advanced Member

  • DOOCrew
  • 27158 posts
  • Gender:Male
  • Location:South Shore, Quebec
  • Interests:1973 Olympic
  • Sled:2007 1000 SDI

Posted 23 February 2021 - 03:52 PM

Is one of the guillotines stuck closed? I wouldn't run it that way for long. How about going through the travel by hand?


Air/Fuel Ratio for two and four strokes
Air/Fuel Ratio for 1200 with boost
Air/Fuel Ratio is measured through emissions
Wideband and EGT
Wideband readings of Air/Fuel Ratio on a two stroke
600 SDI MY2004 Lean/Hot spot running 6900-7000 rpm @ 40-45% Throttle Opening
800R Cranking Compression
800R Oil Injection / Premix combo
800R P-TEK Electrical Troubleshooting #1 and #2 
800R Turbo
850 Center Oil line for coolant pump melted
850 Main Oil line caught fire #1 and #2
900 ACE Turbo - muffler turning red hot
1200 4-TEC Mapping
1200 4-TEC MY 2009 to 2011 Fuel Line issues that could cause a fire
Batteries
Belt Blowers: Overview of UPMICHIGANDER's and Ronn's experience
BUDS 3.3.0 won't connect to SDI
BUDS not connecting to HO or SDI - Try a CanDoo
CVT efficiency - BlueMax
Deep snow intake for XP chassis
Electrical - Diagnoses of a failed ECM
Electrical - 30A Battery Charging Fuse Socket Diagnoses and Relay
Electrical - Relay Coil Wine
Electrical - Relay Testing
Electrical - Battery Charging Relay Diagnostic 
Electrical - Troubleshooting with BRP video 
Electrical - Solder vs Crimp
Electrical - Diagram for Fanners on page 3
Engine Break-In 
Engine Weight 
E-TEC 600HO Clutching
E-TEC Oil Pump
E-TEC Dial-A-Jet
E-TEC Electric Start troubleshooting
E-TEC Engine Management
E-TEC eRAVE position code recurring
E-TEC Stator fault codes P1562 or P1563
E-TEC Capacitor Charge Hold Test and Residual Voltage Test
E-TEC Voltage Rectifier Regulator troubleshooting
E-TEC Power Fades are not normal and can be fixed
Fuel Issues: Could new Ester type oxygenated additives be deteriorating the Fuel Sender Grommet?
Fuel pump and regulator replacement for ACE, E-TEC and SDI
Gasoline quality and storage
Bad Gas for a Two Stroke - Is it a Myth ?
GNR CVT Alignment for the G4
Grip N Rip Clutch Alignment testing
G4 Clutch Alignment, Engine Movement, Sheave Runout and Clutching
G4 850 Throttle Jerkiness solved with clutching
G4 850 Snappy throttle/clutch engagement
G4 850 pDrive tech - A question of Engineering
G4 Steering
G4 850 Tuned Pipe @ 12.6 lbs and Muffler @ 15.4 lbs vs 800R and 800RE muffler weight
Longevity - 800R E-TEC 
Mikuni o-ring for carb float assembly - Arctic Cat part# 6505-875 or from Amazon and eBay
Muffler Red Hot
Off-trail riding for flatlanders
Oil versus Fuel consumption
Pictures - How to resize and upload to DooTalk
Pictures - How to post with the correct orientation
Pipe Pressure testing on a dyno
Pipe Pressure testing from LRD (#1) and (#2)
Pipe Pressure testing results from BRP
Power Loss - How to diagnose in the field
Power at the Crankshaft vs Track - BlueMax
Power Curves: 600 HOE (E-TEC)
Power Curves: 600 vs 800 vs 850 vs 1000 vs 1200
Power Curves: 1000 vs 800 vs 600
Power curves: 800RE 2010.5 to 2016 vs 2016.5 850
Quebec/NY State border crossing
REV Gen1 Gauge Display stuck on "SCALE"
REV Gen1 Volt and Temp Gauge install
REV Gen1 electrical connectors for sensors and MPEM (Multi Purpose Engine Module)
Seafoam for E-TEC injectors
Shortblock or Rebuild?
Ski-Doo Snowmobile Tech Training
Spark Plugs cracked
Squish - The limit
Squish - A discussion on head design
Stator and Relay Diagnostic 
Stator testing for E-TEC using a T harness/Bridge
Stator testing for 1200 4-TEC
Stator Removal on page 3
Stator replacement for a 1200 4-TEC
Suspension Adjustment
Triples - Coolant Pump Assembly
Y-Pipe bolts loosening fix




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users