1.5 IceRipper defect ? - REV-GEN 4 - MXZ Performance Trail 129/ Renegade 137 - DOOTalk Forums

Jump to content

 






Photo

1.5 IceRipper defect ?


  • Please log in to reply
9 replies to this topic

#1 Xpea

Xpea

    Member

  • Members
  • PipPip
  • 23 posts
  • Gender:Male
  • Location:North Western Ontario
  • Sled:1200 GSX

Posted 21 November 2020 - 05:02 PM

 So my bud was centering his 1.5in ice ripper in his Gen 4 850 Renegade when he noticed a wobble as it rotated. He put a straight edge across the area and this is what it looks like. The almost 1/4in deviation goes across the track and bulges out on the other side including the lugs and clips. Ive never seen anything like it before. Its like when the tread on your car tire de-laminates. Is this track safe? thanks for the help

20201120_110526.jpg
 

Attached Images

  • 20201120_110550.jpg

Edited by Xpea, 21 November 2020 - 05:04 PM.


#2 Skandic Wide Track

Skandic Wide Track

    Advanced Member

  • Members
  • PipPipPip
  • 851 posts
  • Gender:Male
  • Location:Durham, maine
  • Sled:1995 skandic wt

Posted 21 November 2020 - 06:56 PM

That sucks really. I'd say its safe but it would "edit for bad language" me off to know that I'd have to redo the job because of that defect.

#3 stealth bomber

stealth bomber

    Advanced Member

  • Members
  • PipPipPip
  • 13010 posts
  • Gender:Male
  • Interests:Running over snowflakes
  • Sled:2020 XRS 850

Posted 21 November 2020 - 07:18 PM

It’s probably safe, but I would be concerned with vibration and longevity issues. Is this a brand new track? I’d be looking to exchange it if so.

#4 SledWreck

SledWreck

    Advanced Member

  • Members
  • PipPipPip
  • 1188 posts
  • Gender:Male
  • Location:Ontario Canada
  • Sled:2016 MXZ 1200X 129

Posted 21 November 2020 - 07:51 PM

Is this on a new 2021?

-------------------------------

Buy it, Ride it, MOD it, Tune it, Repeat ....

 

My 1200 iron dog , Venting 1200 , CVT Cover MOD , SKI Scratcher MOD


#5 DTXRSB

DTXRSB

    Advanced Member

  • Members
  • PipPipPip
  • 3251 posts
  • Gender:Male
  • Location:Plymouth Area-MN
  • Sled:15 XRS 800 Shorty

Posted 21 November 2020 - 08:06 PM

That's nothing compared to Talon tracks! HA!



#6 mile9c1

mile9c1

    Advanced Member

  • Members
  • PipPipPip
  • 2693 posts
  • Gender:Male
  • Location:Grand Rapids, MI
  • Sled:SB 800

Posted 21 November 2020 - 08:33 PM

Are the lugs off as well? I don't think it will cause any unusual issues, as long as the lugs are straight.

#7 Xpea

Xpea

    Member

  • Members
  • PipPip
  • 23 posts
  • Gender:Male
  • Location:North Western Ontario
  • Sled:1200 GSX

Posted 22 November 2020 - 07:42 AM

 I think his sled is a 2019 so it had some miles on it before the flaw was discovered. He had mentioned before that it has some vibration at speed but put it down to a large lug track. With a straight edge against the track you can see in the top picture that the lug follows the the wobble but to a lesser degree, perhaps 3/16in or so. When you look its noticeable.  Still the belts obviously arent straight and are under considerable load. Ive never seen anything like it.


Edited by Xpea, 22 November 2020 - 07:45 AM.


#8 mile9c1

mile9c1

    Advanced Member

  • Members
  • PipPipPip
  • 2693 posts
  • Gender:Male
  • Location:Grand Rapids, MI
  • Sled:SB 800

Posted 22 November 2020 - 01:42 PM

Looks like a clear manufacturing defect to me. 1.5 Ice Rippers have only been out for 1 season so it should still be covered under the manufacturer's warranty. Act fast though.

#9 mark32786

mark32786

    Advanced Member

  • Members
  • PipPipPip
  • 424 posts
  • Gender:Male
  • Sled:17 "edit for bad language" kitty. 04 mxz 600

Posted 22 November 2020 - 05:41 PM

Long shoot but is the rod broke ?   You’d probably have to loosen the track up a lot to flex that area 

2nd thing it could be where the track was heat pressed together.   Person doing it could have had it slightly off center or overheated the track when pressing it together at the factory  



#10 Xpea

Xpea

    Member

  • Members
  • PipPip
  • 23 posts
  • Gender:Male
  • Location:North Western Ontario
  • Sled:1200 GSX

Posted 24 November 2020 - 09:30 AM

No broken rods but I think your right the operator prob fell asleep at the press.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users