Predictions on what happened to this 850? - REV-GEN 4 - MXZ Performance Trail 129/ Renegade 137 - DOOTalk Forums

Jump to content

 






Photo

Predictions on what happened to this 850?


  • Please log in to reply
36 replies to this topic

#1 schreibdave

schreibdave

    Advanced Member

  • Members
  • PipPipPip
  • 1272 posts
  • Gender:Male
  • Location:Manlius, NY
  • Sled:2020 900 Enduro, 2019 850 TNT

Posted 07 March 2020 - 07:44 PM

My son was cruising along on his 2019 850 when it suddenly lost power and then started smoking - we think from coolant spraying around the engine compartment.  He says that when he took the side panels off it was very hot.  Got towed back to truck and then started it to drive it up into the bed.  Says he saw no warning lights.  Still under warranty.  Thoughts?



#2 Gade17

Gade17

    Advanced Member

  • Members
  • PipPipPip
  • 294 posts
  • Gender:Male
  • Sled:Ski-Doo Backcountry-XRS 850

Posted 07 March 2020 - 07:46 PM

Was their coolant left in the sled?


Sent from my iPhone using Tapatalk

2020 BC-XRS 146" x 2"


#3 mike0chek

mike0chek

    Banshee Builder

  • Members
  • PipPipPip
  • 4775 posts
  • Gender:Male
  • Location:New Brunswick, Canada
  • Interests:cold temps, deep snow, banshees
  • Sled:2019 backcountry 850 XRS 10,425 Miles

Posted 07 March 2020 - 07:52 PM

i was with a 19' BCxrs this year that you could smell burnt coolant coming off it. turned out to be a cracked cylinder. he had over 5k miles on the motor. 



#4 Radicalrex

Radicalrex

    Advanced Member

  • Members
  • PipPipPip
  • 350 posts
  • Gender:Male
  • Location:WNY
  • Interests:Sleds,Bikes, wheelers, Toys.
  • Sled:19 Gade X 850

Posted 07 March 2020 - 08:14 PM

19s had a hose clamp recall..7e0a868879b48e50749b922f95949511.jpg


Sent from my iPad using Tapatalk
Lead, follow or get out of the way..

#5 schreibdave

schreibdave

    Advanced Member

  • Members
  • PipPipPip
  • 1272 posts
  • Gender:Male
  • Location:Manlius, NY
  • Sled:2020 900 Enduro, 2019 850 TNT

Posted 07 March 2020 - 08:33 PM

Was their coolant left in the sled?


Sent from my iPhone using Tapatalk

I will take a look in the morning.

 

 

19s had a hose clamp recall..7e0a868879b48e50749b922f95949511.jpg


Sent from my iPad using Tapatalk

 

I know that the newer clamp is on there.  I checked that when we took delivery.

 

Will post again after I get a look at it in the morning.



#6 Powder dave

Powder dave

    Advanced Member

  • Members
  • PipPipPip
  • 439 posts
  • Gender:Male
  • Location:Nantucket Mass
  • Interests:Anything with an engine, fishing, shooting, hockey,
    Previous sled 2014 Renegade X , anything outdoors and I’m good
  • Sled:2019 Backcountry 850

Posted 07 March 2020 - 09:56 PM

The fact it lost power is probably more than a hose!
SUMMER SUCKS!!

#7 mikmaze

mikmaze

    Advanced Member

  • Members
  • PipPipPip
  • 2452 posts
  • Gender:Male
  • Location:Fairfield NJ/ ride Chenango cty NY
  • Interests:Hunting, quads, diesel performance, sledding, Bourbon!
    sold:2003 mxz800
  • Sled:2009 MXZ 800R ADRENALIN

Posted 07 March 2020 - 10:29 PM

enough coolant spray out of the hose to wet down a plug, run on half the motor/



#8 budko

budko

    Advanced Member

  • Members
  • PipPipPip
  • 870 posts
  • Gender:Female
  • Location:Montreal, Quebec
  • Interests:Previous sleds:
    2004 Legend 500ss
    2007 GTX 500ss
    2011 MXZ TNT 600 ace
    2013 MXZ X 600 e-tec
    2016 MXZ X 800 e-tec
    2018 MXZ X 850 e-tec
    2020 MXZ X 850 e-tec
  • Sled:2021 Renny X 850 e-tec

Posted 07 March 2020 - 11:41 PM

19s had a hose clamp recall..7e0a868879b48e50749b922f95949511.jpg

 

Photo credit for photo above= Budko from our 2019 Renny X 850.


Sent from my iPad using Tapatalk



#9 budko

budko

    Advanced Member

  • Members
  • PipPipPip
  • 870 posts
  • Gender:Female
  • Location:Montreal, Quebec
  • Interests:Previous sleds:
    2004 Legend 500ss
    2007 GTX 500ss
    2011 MXZ TNT 600 ace
    2013 MXZ X 600 e-tec
    2016 MXZ X 800 e-tec
    2018 MXZ X 850 e-tec
    2020 MXZ X 850 e-tec
  • Sled:2021 Renny X 850 e-tec

Posted 07 March 2020 - 11:50 PM

19s had a hose clamp recall..7e0a868879b48e50749b922f95949511.jpg


Sent from my iPad using Tapatalk

 


After repair 

Attached Images

  • A1606091-DA7A-4429-89DA-01B7250532ED.jpeg


#10 budko

budko

    Advanced Member

  • Members
  • PipPipPip
  • 870 posts
  • Gender:Female
  • Location:Montreal, Quebec
  • Interests:Previous sleds:
    2004 Legend 500ss
    2007 GTX 500ss
    2011 MXZ TNT 600 ace
    2013 MXZ X 600 e-tec
    2016 MXZ X 800 e-tec
    2018 MXZ X 850 e-tec
    2020 MXZ X 850 e-tec
  • Sled:2021 Renny X 850 e-tec

Posted 08 March 2020 - 12:08 AM

Coolant hose just blew off due to faulty clamp.

There was a recall bulletin January 2019.

Lesson learned = don’t wait for dealer. Check the recalls yourself.

 

I’ve been trying to load more pictures but DooTalk isn’t accepting them.

 

It was careless of the dealer to not check the bulletin when the pre-season tuen up was done. 

 

The coolant leak left us stranded. Luckily we were close and were able to get the sled to safety.

 

We had other issues all winter. We have been riding 850s since they were 1st released and ride 6500-7000Km a year. We never had problems like we had this year. We trace many of them back to this coolant leak.



#11 schreibdave

schreibdave

    Advanced Member

  • Members
  • PipPipPip
  • 1272 posts
  • Gender:Male
  • Location:Manlius, NY
  • Sled:2020 900 Enduro, 2019 850 TNT

Posted 08 March 2020 - 06:21 AM

Budko - mine had the recall done.  I checked that shortly after we took delivery.  Here's a picture.  Once it gets light out I will go take a look.

 

8950 hose clamp.jpg



#12 schreibdave

schreibdave

    Advanced Member

  • Members
  • PipPipPip
  • 1272 posts
  • Gender:Male
  • Location:Manlius, NY
  • Sled:2020 900 Enduro, 2019 850 TNT

Posted 08 March 2020 - 11:00 AM

U guys who predicted the clamp were right. So even though it appears to have the update the ckamp still came off. Having said that i wonder if it did some motor damage because when starting it to get it off the truck it is definitely underpowered. Something else is going on. Maybe coolant sucked into the motor?20200308_101336.jpg

#13 MX-Z Man

MX-Z Man

    Advanced Member

  • Moderators
  • PipPipPip
  • 27771 posts
  • Gender:Male
  • Location:Tug Hill Area, NY
  • Sled:'19 850X, Outlander 650XT, & Defender XT

Posted 08 March 2020 - 11:05 AM

Lost coolant, went into limp mode? 

 

Or blew a head gasket and over-pressurized the system, pushing the hose off? 


gallery_5_57_615.jpg

The XP was the most fun sled ever made - but I liked my XR more. The 850 takes it to a whole different level. 

No Need to Freeze-buy a set of these! http://www.coldguards.com/


#14 DOOtym

DOOtym

    Advanced Member

  • Members
  • PipPipPip
  • 1436 posts
  • Gender:Male
  • Location:SW Ontario
  • Sled:19 Gade XRS - 08 XP 600

Posted 08 March 2020 - 11:48 AM

Wonder if you could post what other issues you've had this year that you believe were related to the coolant loss issue you had budko? They may now be relevant to the OP, as well as others that may not be aware of additional consequences due to that.

Sent from my SM-G975F using Tapatalk

Edited by DOOtym, 08 March 2020 - 11:49 AM.

Mainway Solutions Greasable Suspension Components

Elka Shocks

Cudney Clutch kit

24/45 Gearing

1.5" Ripsaw 126 Studboy / Superlight Pro backers

Grip-n-Rip Bracing


#15 skippydoo

skippydoo

    Advanced Member

  • Members
  • PipPipPip
  • 3351 posts
  • Gender:Male
  • Location:NJ
  • Interests:Sledding, dirt track racing, and shocks

  •    

Posted 08 March 2020 - 12:06 PM

Once you push the coolant out of the motor , the temp gauge can't read  temperature.  What worries me is, you lost power.   






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users