Connection from sled to Oxygen helmet not working - REV-GEN 4 - MXZ Performance Trail 129/ Renegade 137 - DOOTalk Forums

Jump to content

 






Photo

Connection from sled to Oxygen helmet not working

Renegade 850 visor helmet electric

  • Please log in to reply
5 replies to this topic

#1 Tee Triton

Tee Triton

    Member

  • Members
  • PipPip
  • 10 posts
  • Gender:Male
  • Location:near Smiths Falls, Ontario
  • Sled:2019 Ski Doo Renegade X 850

Posted 19 January 2020 - 07:04 PM

My connection on my 850 Renegade X is not workig.

It did last year, but not now.

 

I attempted to use my new Oxygen helmet, and that is how I found out.

It worked on my buddies sled.

 

Are there any videos or suggestions on what I would look for or how to fix please?

 

Any suggestions are appreciated.


2019 Ski Doo Renegade X 850

2016 Ski Doo MXZ X 800 etec

2016 Ski Doo Mxz 600

2014 Can Am 650 XT

1984 john deere liquid fire

1980 yamaha 433 gpx free air

1973 Olympic


#2 DareDog

DareDog

    E-Tec Rules

  • DOOCrew
  • 32371 posts
  • Gender:Male
  • Location:Sherrill NY
  • Sled:2010 600 Etec

Posted 19 January 2020 - 07:50 PM

My connection on my 850 Renegade X is not workig.
It did last year, but not now.

I attempted to use my new Oxygen helmet, and that is how I found out.
It worked on my buddies sled.

Are there any videos or suggestions on what I would look for or how to fix please?

Any suggestions are appreciated.

check the fuse on the plug.


Sent from my iPhone using Tapatalk
  • krm likes this

Current Fleet:
1998 Formula III 700-14,000 Miles
2004 600ho- 18,300 Miles
2005 500ss- 9,500 Miles
2010 600 HO Etec- 13,000 Miles

2016 600 HO Etec Blizzard-7,500 Miles 

2016 600 HO Etec Blizzard- 5,000 Miles

2017 600 Ace Blizzard - 1,350 Miles 

(2) 1975 245 RV 

1964 skidoo four cycle

1964 huski 


#3 Tee Triton

Tee Triton

    Member

  • Members
  • PipPip
  • 10 posts
  • Gender:Male
  • Location:near Smiths Falls, Ontario
  • Sled:2019 Ski Doo Renegade X 850

Posted 19 January 2020 - 08:08 PM

thank you


2019 Ski Doo Renegade X 850

2016 Ski Doo MXZ X 800 etec

2016 Ski Doo Mxz 600

2014 Can Am 650 XT

1984 john deere liquid fire

1980 yamaha 433 gpx free air

1973 Olympic


#4 Tee Triton

Tee Triton

    Member

  • Members
  • PipPip
  • 10 posts
  • Gender:Male
  • Location:near Smiths Falls, Ontario
  • Sled:2019 Ski Doo Renegade X 850

Posted 20 January 2020 - 07:14 PM

Are there more than the 4 fuses?

All 4 are still good.

 

Any thoughts?


2019 Ski Doo Renegade X 850

2016 Ski Doo MXZ X 800 etec

2016 Ski Doo Mxz 600

2014 Can Am 650 XT

1984 john deere liquid fire

1980 yamaha 433 gpx free air

1973 Olympic


#5 Wink1

Wink1

    Advanced Member

  • Members
  • PipPipPip
  • 4794 posts
  • Gender:Male
  • Location:Celina, Ohio
  • Interests:Sledding, classic cars (don’t own one but I like them), watching my grandson play ball.
  • Sled:2018 850 XRS 129

Posted 20 January 2020 - 07:25 PM

The one for the heated shield is up above the secondary under the cowling. It is a pain in the rear to get to if you don’t know where to look. Might be easier to take your hood off to see it if you can’t find it. It’s in the wire itself, not in a fuse block.



#6 Djetski225

Djetski225

    Advanced Member

  • Members
  • PipPipPip
  • 1227 posts
  • Gender:Male
  • Location:NE Pa
  • Sled:2016 MXZX 600HO

Posted 20 January 2020 - 07:42 PM

Yep, prob the fuse. May have been a chance that you had a heated shield cord loose when plugged in and it grounded out on something metal? I always try to unplug mine so the male end of the cord is coming from your coat. That leaves the female side with the power on it.





Also tagged with one or more of these keywords: Renegade, 850, visor, helmet, electric

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users