Anyone an expert on the 600SDI engines? - Page 3 - REV Chassis - Performance and Trail Models - DOOTalk Forums

Jump to content

 






Photo

Anyone an expert on the 600SDI engines?


  • Please log in to reply
188 replies to this topic

#31 FlavorDave

FlavorDave

    Advanced Member

  • Members
  • PipPipPip
  • 317 posts
  • Gender:Male
  • Location:Cascade Mountains, Oregon
  • Sled:2020 Renegade 850

Posted 30 March 2019 - 07:15 PM

Thanks everyone.

Is it possible to reset the TPS if BUDS wasn’t able to talk to the ECU?

Harbor Freight is my Sponsor. 


#32 Daag44

Daag44

    Advanced Member

  • DOOCrew
  • 25133 posts
  • Gender:Male
  • Location:South Shore, Quebec
  • Interests:1973 Olympic
  • Sled:2007 1000 SDI

Posted 30 March 2019 - 07:23 PM

No, but it is possible they had it connected and are no longer able to. That is a likely scenario. Not all techs understand the effects of causing shorts and voltage spikes on the SDI. And ETEC for that matter.


Air/Fuel Ratio for two and four strokes
Air/Fuel Ratio for 1200 with boost
Air/Fuel Ratio is measured through emissions
Wideband and EGT
Wideband readings of Air/Fuel Ratio on a two stroke
600 SDI MY2004 Lean/Hot spot running 6900-7000 rpm @ 40-45% Throttle Opening
800R Cranking Compression
800R Oil Injection / Premix combo
800R Turbo?
900 ACE Turbo - muffler turning red hot
1200 4-TEC Mapping
1200 4-TEC MY 2009 to 2011 Fuel Line issues that could cause a fire
Batteries
Belt Blowers: Overview of UPMICHIGANDER's experience
BUDS 3.3.0 won't connect to SDI
BUDS not connecting to HO or SDI - Try a CanDoo
CVT efficiency - BlueMax
Deep snow intake for XP chassis
Diagnoses
E-TEC 600HO Clutching
E-TEC Oil Pump
E-TEC Dial-A-Jet
E-TEC Engine Management
E-TEC Stator fault codes P1562 or P1563
E-TEC Capacitor Charge Hold Test and Residual Voltage Test
Fuel Issues: Could new Ester type oxygenated additives be deteriorating the Fuel Sender Grommet?
Fuel pump and regulator replacement for ACE, E-TEC and SDI
Gasoline quality and storage
Bad Gas for a Two Stroke - Is it a Myth ?
G4 Clutch Alignment, Engine Movement, Sheave Runout and Clutching
GNR CVT Alignment for the G4
Grip N Rip Clutch Alignment testing
G4 850 Throttle Jerkiness solved with clutching
G4 850 Snappy throttle/clutch engagement
G4 850 pDrive tech - A question of Engineering
G4 850 Tuned Pipe @ 12.6 lbs and Muffler @ 15.4 lbs vs 800R and 800RE muffler weight
Pictures - How to resize and upload to DooTalk
Pipe Pressure testing on a dyno
Pipe Pressure testing from LRD (#1) and (#2)
Pipe Pressure testing results from BRP
Oil versus Fuel consumption
Power at the Crankshaft vs Track - BlueMax
Power Curves: 600 HOE (E-TEC)
Power Curves: 600 vs 800 vs 850 vs 1000 vs 1200
Power Curves: 1000 vs 800 vs 600
Power curves: 800RE 2010.5 to 2016 vs 2016.5 850
Quebec/NY State border crossing
REV Gen1 Gauge Display stuck on "SCALE"
REV Gen1 Volt and Temp Gauge install
REV Gen1 electrical connectors for sensors and MPEM (Multi Purpose Engine Module)
Shortblock or Rebuild?
Ski-Doo Snowmobile Tech Training
Stator testing for E-TEC using a T harness/Bridge
Stator testing for 1200 4-TEC
Stator replacement for a 1200 4-TEC
Suspension Adjustment
Triples - Coolant Pump Assembly
Y-Pipe bolts loosening fix


#33 Daag44

Daag44

    Advanced Member

  • DOOCrew
  • 25133 posts
  • Gender:Male
  • Location:South Shore, Quebec
  • Interests:1973 Olympic
  • Sled:2007 1000 SDI

Posted 30 March 2019 - 07:26 PM

So you'll really need to pry to get what actually happened. You may need to find another ECM or go find a shop that has a CanDoo.


Air/Fuel Ratio for two and four strokes
Air/Fuel Ratio for 1200 with boost
Air/Fuel Ratio is measured through emissions
Wideband and EGT
Wideband readings of Air/Fuel Ratio on a two stroke
600 SDI MY2004 Lean/Hot spot running 6900-7000 rpm @ 40-45% Throttle Opening
800R Cranking Compression
800R Oil Injection / Premix combo
800R Turbo?
900 ACE Turbo - muffler turning red hot
1200 4-TEC Mapping
1200 4-TEC MY 2009 to 2011 Fuel Line issues that could cause a fire
Batteries
Belt Blowers: Overview of UPMICHIGANDER's experience
BUDS 3.3.0 won't connect to SDI
BUDS not connecting to HO or SDI - Try a CanDoo
CVT efficiency - BlueMax
Deep snow intake for XP chassis
Diagnoses
E-TEC 600HO Clutching
E-TEC Oil Pump
E-TEC Dial-A-Jet
E-TEC Engine Management
E-TEC Stator fault codes P1562 or P1563
E-TEC Capacitor Charge Hold Test and Residual Voltage Test
Fuel Issues: Could new Ester type oxygenated additives be deteriorating the Fuel Sender Grommet?
Fuel pump and regulator replacement for ACE, E-TEC and SDI
Gasoline quality and storage
Bad Gas for a Two Stroke - Is it a Myth ?
G4 Clutch Alignment, Engine Movement, Sheave Runout and Clutching
GNR CVT Alignment for the G4
Grip N Rip Clutch Alignment testing
G4 850 Throttle Jerkiness solved with clutching
G4 850 Snappy throttle/clutch engagement
G4 850 pDrive tech - A question of Engineering
G4 850 Tuned Pipe @ 12.6 lbs and Muffler @ 15.4 lbs vs 800R and 800RE muffler weight
Pictures - How to resize and upload to DooTalk
Pipe Pressure testing on a dyno
Pipe Pressure testing from LRD (#1) and (#2)
Pipe Pressure testing results from BRP
Oil versus Fuel consumption
Power at the Crankshaft vs Track - BlueMax
Power Curves: 600 HOE (E-TEC)
Power Curves: 600 vs 800 vs 850 vs 1000 vs 1200
Power Curves: 1000 vs 800 vs 600
Power curves: 800RE 2010.5 to 2016 vs 2016.5 850
Quebec/NY State border crossing
REV Gen1 Gauge Display stuck on "SCALE"
REV Gen1 Volt and Temp Gauge install
REV Gen1 electrical connectors for sensors and MPEM (Multi Purpose Engine Module)
Shortblock or Rebuild?
Ski-Doo Snowmobile Tech Training
Stator testing for E-TEC using a T harness/Bridge
Stator testing for 1200 4-TEC
Stator replacement for a 1200 4-TEC
Suspension Adjustment
Triples - Coolant Pump Assembly
Y-Pipe bolts loosening fix


#34 FlavorDave

FlavorDave

    Advanced Member

  • Members
  • PipPipPip
  • 317 posts
  • Gender:Male
  • Location:Cascade Mountains, Oregon
  • Sled:2020 Renegade 850

Posted 30 March 2019 - 08:33 PM

No, but it is possible they had it connected and are no longer able to. That is a likely scenario. Not all techs understand the effects of causing shorts and voltage spikes on the SDI. And ETEC for that matter.


So they may have caused a short and I’ll have to buy a new ECM? Fantastic.

This is the first time I’ve ever taken a machine to a dealership for work. I’ve always done repairs myself. This is becoming a nightmare....

Harbor Freight is my Sponsor. 


#35 Gordo427

Gordo427

    Advanced Member

  • Members
  • PipPipPip
  • 2546 posts
  • Gender:Male
  • Location:CT
  • Sled:Mxz800 mxz600 ho mzx600 Sdi 850 renagade

Posted 30 March 2019 - 09:07 PM

Just my two cents I have two sdi I can disconnect exhaust sens or coolant sled still runs just get check engine light I know this was a long thread your sled didn’t run right. If it won’t run I’m sure as dealer they would do the basics if it has spark check fuel. Let me know I have two in my garage now and can try what ever you want

Edited by Gordo427, 30 March 2019 - 09:09 PM.


#36 Daag44

Daag44

    Advanced Member

  • DOOCrew
  • 25133 posts
  • Gender:Male
  • Location:South Shore, Quebec
  • Interests:1973 Olympic
  • Sled:2007 1000 SDI

Posted 30 March 2019 - 10:02 PM

So they may have caused a short and I’ll have to buy a new ECM? Fantastic.

This is the first time I’ve ever taken a machine to a dealership for work. I’ve always done repairs myself. This is becoming a nightmare....

 
I actually created a rabbit hole without realizing it, and I know better. Shorting out a ECM isn't common, so scratch that. And I won't dig anymore of those...


Air/Fuel Ratio for two and four strokes
Air/Fuel Ratio for 1200 with boost
Air/Fuel Ratio is measured through emissions
Wideband and EGT
Wideband readings of Air/Fuel Ratio on a two stroke
600 SDI MY2004 Lean/Hot spot running 6900-7000 rpm @ 40-45% Throttle Opening
800R Cranking Compression
800R Oil Injection / Premix combo
800R Turbo?
900 ACE Turbo - muffler turning red hot
1200 4-TEC Mapping
1200 4-TEC MY 2009 to 2011 Fuel Line issues that could cause a fire
Batteries
Belt Blowers: Overview of UPMICHIGANDER's experience
BUDS 3.3.0 won't connect to SDI
BUDS not connecting to HO or SDI - Try a CanDoo
CVT efficiency - BlueMax
Deep snow intake for XP chassis
Diagnoses
E-TEC 600HO Clutching
E-TEC Oil Pump
E-TEC Dial-A-Jet
E-TEC Engine Management
E-TEC Stator fault codes P1562 or P1563
E-TEC Capacitor Charge Hold Test and Residual Voltage Test
Fuel Issues: Could new Ester type oxygenated additives be deteriorating the Fuel Sender Grommet?
Fuel pump and regulator replacement for ACE, E-TEC and SDI
Gasoline quality and storage
Bad Gas for a Two Stroke - Is it a Myth ?
G4 Clutch Alignment, Engine Movement, Sheave Runout and Clutching
GNR CVT Alignment for the G4
Grip N Rip Clutch Alignment testing
G4 850 Throttle Jerkiness solved with clutching
G4 850 Snappy throttle/clutch engagement
G4 850 pDrive tech - A question of Engineering
G4 850 Tuned Pipe @ 12.6 lbs and Muffler @ 15.4 lbs vs 800R and 800RE muffler weight
Pictures - How to resize and upload to DooTalk
Pipe Pressure testing on a dyno
Pipe Pressure testing from LRD (#1) and (#2)
Pipe Pressure testing results from BRP
Oil versus Fuel consumption
Power at the Crankshaft vs Track - BlueMax
Power Curves: 600 HOE (E-TEC)
Power Curves: 600 vs 800 vs 850 vs 1000 vs 1200
Power Curves: 1000 vs 800 vs 600
Power curves: 800RE 2010.5 to 2016 vs 2016.5 850
Quebec/NY State border crossing
REV Gen1 Gauge Display stuck on "SCALE"
REV Gen1 Volt and Temp Gauge install
REV Gen1 electrical connectors for sensors and MPEM (Multi Purpose Engine Module)
Shortblock or Rebuild?
Ski-Doo Snowmobile Tech Training
Stator testing for E-TEC using a T harness/Bridge
Stator testing for 1200 4-TEC
Stator replacement for a 1200 4-TEC
Suspension Adjustment
Triples - Coolant Pump Assembly
Y-Pipe bolts loosening fix


#37 FlavorDave

FlavorDave

    Advanced Member

  • Members
  • PipPipPip
  • 317 posts
  • Gender:Male
  • Location:Cascade Mountains, Oregon
  • Sled:2020 Renegade 850

Posted 31 March 2019 - 12:20 AM

Just to be accurate, the service manager says that the sled starts, but will not idle or stay running.

And Daag, I’m not falling down any rabbit holes. I appreciate your help with this. I’m just a little frustrated by this whole mess.

Harbor Freight is my Sponsor. 


#38 Daag44

Daag44

    Advanced Member

  • DOOCrew
  • 25133 posts
  • Gender:Male
  • Location:South Shore, Quebec
  • Interests:1973 Olympic
  • Sled:2007 1000 SDI

Posted 31 March 2019 - 01:47 AM

Just to be accurate, the service manager says that the sled starts, but will not idle or stay running.

And Daag, I’m not falling down any rabbit holes. I appreciate your help with this. I’m just a little frustrated by this whole mess.

 

I am hoping for the best. From my point of view all it needs is a TPS reset.


Edited by Daag44, 31 March 2019 - 11:13 AM.

Air/Fuel Ratio for two and four strokes
Air/Fuel Ratio for 1200 with boost
Air/Fuel Ratio is measured through emissions
Wideband and EGT
Wideband readings of Air/Fuel Ratio on a two stroke
600 SDI MY2004 Lean/Hot spot running 6900-7000 rpm @ 40-45% Throttle Opening
800R Cranking Compression
800R Oil Injection / Premix combo
800R Turbo?
900 ACE Turbo - muffler turning red hot
1200 4-TEC Mapping
1200 4-TEC MY 2009 to 2011 Fuel Line issues that could cause a fire
Batteries
Belt Blowers: Overview of UPMICHIGANDER's experience
BUDS 3.3.0 won't connect to SDI
BUDS not connecting to HO or SDI - Try a CanDoo
CVT efficiency - BlueMax
Deep snow intake for XP chassis
Diagnoses
E-TEC 600HO Clutching
E-TEC Oil Pump
E-TEC Dial-A-Jet
E-TEC Engine Management
E-TEC Stator fault codes P1562 or P1563
E-TEC Capacitor Charge Hold Test and Residual Voltage Test
Fuel Issues: Could new Ester type oxygenated additives be deteriorating the Fuel Sender Grommet?
Fuel pump and regulator replacement for ACE, E-TEC and SDI
Gasoline quality and storage
Bad Gas for a Two Stroke - Is it a Myth ?
G4 Clutch Alignment, Engine Movement, Sheave Runout and Clutching
GNR CVT Alignment for the G4
Grip N Rip Clutch Alignment testing
G4 850 Throttle Jerkiness solved with clutching
G4 850 Snappy throttle/clutch engagement
G4 850 pDrive tech - A question of Engineering
G4 850 Tuned Pipe @ 12.6 lbs and Muffler @ 15.4 lbs vs 800R and 800RE muffler weight
Pictures - How to resize and upload to DooTalk
Pipe Pressure testing on a dyno
Pipe Pressure testing from LRD (#1) and (#2)
Pipe Pressure testing results from BRP
Oil versus Fuel consumption
Power at the Crankshaft vs Track - BlueMax
Power Curves: 600 HOE (E-TEC)
Power Curves: 600 vs 800 vs 850 vs 1000 vs 1200
Power Curves: 1000 vs 800 vs 600
Power curves: 800RE 2010.5 to 2016 vs 2016.5 850
Quebec/NY State border crossing
REV Gen1 Gauge Display stuck on "SCALE"
REV Gen1 Volt and Temp Gauge install
REV Gen1 electrical connectors for sensors and MPEM (Multi Purpose Engine Module)
Shortblock or Rebuild?
Ski-Doo Snowmobile Tech Training
Stator testing for E-TEC using a T harness/Bridge
Stator testing for 1200 4-TEC
Stator replacement for a 1200 4-TEC
Suspension Adjustment
Triples - Coolant Pump Assembly
Y-Pipe bolts loosening fix


#39 Gordo427

Gordo427

    Advanced Member

  • Members
  • PipPipPip
  • 2546 posts
  • Gender:Male
  • Location:CT
  • Sled:Mxz800 mxz600 ho mzx600 Sdi 850 renagade

Posted 31 March 2019 - 08:44 AM

Even with sensors disonected my sleds idle fine just engine light. No fuel or improper battery voltage would make it not stay running I can send a video with sensors disconceted with sled idling fine

#40 FlavorDave

FlavorDave

    Advanced Member

  • Members
  • PipPipPip
  • 317 posts
  • Gender:Male
  • Location:Cascade Mountains, Oregon
  • Sled:2020 Renegade 850

Posted 31 March 2019 - 12:39 PM

WOW. I’m glad I have access to information on a forum like this. Beyond regular maintenance, I’ve never had to put a wrench on our pair of SDIs.

In 2005, we rented Renegades in West Yellowstone. After riding the new REV, my wife said she would never ride anything else. Nobody in Oregon was renting REVs and I couldn’t find a single one for sale here. In spring of 2006, I called West Yellowstone and asked if they had any leftover rentals. They had a matching pair of 600SDI Renegades, so I hitched up our friends trailer to our VW and headed for Montana.

In the 13 years since, I may have seen two other SDIs here in Oregon. Everyone seems to need a Summit and they all seem to need the 800s. I’ve ridden with several different groups over the years, to some pretty awesome places. It may have required a good deal more effort, but I managed to get there nontheless.

It’s entirely possible that the shops here haven’t seen a single SDI. This dealer has leftover 2019s, and there isn’t a single 600 in the building. I can understand their lack of experience with models or engines that aren’t popular sellers here. My frustration is that the sled has been there since the beginning of February. I’m also wondering how much I will be charged for them trying to figure this out. I was quoted a pretty spendy price for my new engine and installation and more costs would start reaching the top end of the value of the sled itself. With the season now ended, I’m also concerned that any other problems with the installation won’t be discovered until next season.

Maybe I’m being too much of a worry wart.....

Harbor Freight is my Sponsor. 


#41 FlavorDave

FlavorDave

    Advanced Member

  • Members
  • PipPipPip
  • 317 posts
  • Gender:Male
  • Location:Cascade Mountains, Oregon
  • Sled:2020 Renegade 850

Posted 31 March 2019 - 05:41 PM

Even with sensors disonected my sleds idle fine just engine light. No fuel or improper battery voltage would make it not stay running I can send a video with sensors disconceted with sled idling fine


If you would, I’d sure appreciate it.

Harbor Freight is my Sponsor. 


#42 Wiexpress

Wiexpress

    Advanced Member

  • Members
  • PipPipPip
  • 2716 posts
  • Gender:Male
  • Location:Fox Valley WI
  • Sled:600 Carby Backcountry wannabe

Posted 31 March 2019 - 05:53 PM

Another FYI on the SDI if the egr sensor needs replacing, you can get a ac Delco GM sensor for $40 that is the same sensor.

#43 FlavorDave

FlavorDave

    Advanced Member

  • Members
  • PipPipPip
  • 317 posts
  • Gender:Male
  • Location:Cascade Mountains, Oregon
  • Sled:2020 Renegade 850

Posted 31 March 2019 - 06:46 PM

Another FYI on the SDI if the egr sensor needs replacing, you can get a ac Delco GM sensor for $40 that is the same sensor.

Great info to have. Thanks.

Wait, the SDI has an EGR??

Edited by FlavorDave, 31 March 2019 - 06:48 PM.

Harbor Freight is my Sponsor. 


#44 Killer-Beez

Killer-Beez

    Advanced Member

  • Members
  • PipPipPip
  • 2922 posts
  • Gender:Male
  • Sled:2007 Renegade

Posted 31 March 2019 - 07:03 PM

Yep it does it's in the top of the muffler

#45 FlavorDave

FlavorDave

    Advanced Member

  • Members
  • PipPipPip
  • 317 posts
  • Gender:Male
  • Location:Cascade Mountains, Oregon
  • Sled:2020 Renegade 850

Posted 01 April 2019 - 10:33 PM

*UPDATE

I texted the service manager and asked him how he reset the TPS if he couldn’t get BUDS to communicate with the sled.

He replied: “Dave, I spoke out of turn I apologize. Still trying to get communication with unit. We have BUDS 3.3.0 which is all units prior to 2007. We've checked it for updates and re-installed it with no success.”

Earlier he had told me that they DID reset the TPS in a text.

I’m really starting to think the worst here.....

Harbor Freight is my Sponsor. 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users