Boot failure - REV-GEN 4 - Summit/Freeride/ 850 Turbo - DOOTalk Forums

Jump to content

 






Photo

Boot failure

boot G4 850

  • Please log in to reply
63 replies to this topic

#1 KellyTataryn

KellyTataryn

    Newbie

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Sled:2017 Summit x 850 154

Posted 19 December 2016 - 11:55 AM

Has anyone had any problems with the boots failing where they are connected to the s module? Rode all day in some light, fluffy snow yesterday and by the end I had lost steering and both boots were ruptured. Had another 850 in our group as well with the same problem (Pre filter on front grill, mine without). BRP has agreed to warranty both boots, but still its a nuisance.



#2 motox54

motox54

    Advanced Member

  • Members
  • PipPipPip
  • 390 posts
  • Gender:Male
  • Sled:2009 600 RS, 2017 Summit SP 850, 154

Posted 19 December 2016 - 03:23 PM

skid plates or no skid plates?



#3 KellyTataryn

KellyTataryn

    Newbie

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Sled:2017 Summit x 850 154

Posted 19 December 2016 - 06:00 PM

Mine has a skid plate, his does not. Ice is accumulating in the bottom of the engine bay causing the boots to rupture and fail.



#4 brymer159

brymer159

    Advanced Member

  • Members
  • PipPipPip
  • 68 posts
  • Gender:Male
  • Sled:2014 summitX 800 146

Posted 19 December 2016 - 09:38 PM

I had one boot failure. Only 77 miles on mine total. Fluffy snow creeped in at the 6 o'clock part of the boot to belly casting and a constant heat/freeze cycle would make ice just build up on my tie rod and it finally blew out my boot. Waiting to see if they'll warranty it

Edited by brymer159, 19 December 2016 - 09:55 PM.


#5 npickle12

npickle12

    Advanced Member

  • Members
  • PipPipPip
  • 2300 posts
  • Gender:Male
  • Sled:2018 XRS 850, 2009 770 RS

Posted 19 December 2016 - 09:50 PM

Geez. The hits keep coming on these 850s. They've got some redesign to do over the winter!

#6 gauthier

gauthier

    Newbie

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Location:Quebec, Canada
  • Sled:Summit 850 sp

Posted 08 January 2017 - 02:08 PM

Have experienced some bad trip this weekend ... no boots failure but a lot of ice in the boots and steering. The front end of the sled was full on snow that melt down in the steering area and freeze up there while i drive the sled ... so i lost the steering ... almost have accident !! back to camp i have to melt down ice whit hot water ! I think they should put front grill skin at factory !


Summit 850 sp 2017

Tundra xtreme 2015

Tundra 300 2007


#7 Triggerman

Triggerman

    Member

  • Members
  • PipPip
  • 22 posts
  • Gender:Male
  • Sled:17 850

Posted 08 January 2017 - 10:42 PM

The problem is snow coming in the front nose. Even with the pre filter kit installed. Doo didn't actually put any pre filter material in the kit. It's just mesh. Snow will still get in there. I glued pre filter to the outside of the kit and it's been good. No snow under the hood.

#8 stmike

stmike

    Advanced Member

  • Members
  • PipPipPip
  • 4464 posts
  • Gender:Male
  • Location:Val Gagne northern on canada
  • Interests:all the big boys toys
  • Sled:2014 800etec BC 2018 summit X 154

Posted 09 January 2017 - 07:44 AM

Would pet screen work,or is the holes in it to big.



#9 longsled

longsled

    Advanced Member

  • Members
  • PipPipPip
  • 876 posts
  • Gender:Male
  • Location:Lac St-Jean, Qu�bec
  • Sled:Orange X-165 3'' & Black X-165 3''

Posted 09 January 2017 - 11:38 AM

I have busted a set of boots in the 3 first rides. I have  now installed the brp nose filter kit, a skid plate, and the most important I have sealed the bottom of the boots with black urethane for car windshield. The bottom of the boots have no rivets, and there is about a 1/8'' crack between the bulkhead and boots where snow can come in and fill the boots. 300 km this week end in deep lite powder snow and no snow or ice in the boots. problem solved for me.


Edited by longsled, 09 January 2017 - 01:13 PM.

Or/Wh X-165 T3 & BL X-165 T3

2010 & 2011 Daytona Promax race champion


#10 DirtballXRS

DirtballXRS

    Advanced Member

  • Members
  • PipPipPip
  • 318 posts
  • Gender:Male
  • Sled:14 xmx 154

Posted 11 January 2017 - 06:39 PM

This is mine time for ski Doo to come up with fix

Attached Images

  • IMG_1935.JPG
  • IMG_1940.JPG
  • IMG_1940.JPG

Wheres the snow at???

68 olympic
01 mxz 380
02 mxz 800
07 xrs 800

14 xmx 154


#11 ferniesnow

ferniesnow

    I'm Dooing It

  • Members
  • PipPipPip
  • 3966 posts
  • Gender:Not Telling
  • Location:Kootenay's BC, Canada
  • Interests:Sledding and improving the sledding environment for the masses.
  • Sled:2017 G4 165 with ES and all wrapped up!


  •    

Posted 12 January 2017 - 05:18 PM

Would pet screen work,or is the holes in it to big.

Pet screen works if the snow isn't too dry. Our mountain snow collects on the outside os the pet screen and seals the front off great. I have buddies who ride in colder temps and the fine snow dust just goes right through it. The require the pre-filter screen material. 


ferniesnow on YouTube; over 100 great, action packed videos for you to enjoy!

http://www.youtube.c...ow?feature=mhee


#12 Idahodoo

Idahodoo

    JCs Custom Vents

  • Sponsors
  • 3822 posts
  • Gender:Male
  • Location:Pocatello Idaho
  • Interests:Authorized Factory Direct Dealer
    See Avatar
  • Sled:2017 G4 165 X. Blue On Black

Posted 12 January 2017 - 07:32 PM

Mine has a skid plate, his does not. Ice is accumulating in the bottom of the engine bay causing the boots to rupture and fail.


I found large gaps around the front bumper that I sealed up that I didn't like the looks of , that maybe a something to look at.

JCsCustomVents.com

2017 Skidoo G4 165 X   :ride:

2013 Skidoo XM 163 X (Great Sled)

2012 Polaris 800 Pro (Mistake)

2008 Skidoo XP 154 X (Great Sled) 

2004 Rev 151 X(Great Sled)

2004 Rev 136 Orange (Good Sled)

1998 RMK 700 (Great Sled)

1995 XLT 600 SKS(Great Sled)

1990 RXL 650 (Pile)

1985 Indy 600 (wheelie King) 

1984 Yamaha V Max (junk)

1982 Yamaha 440 SS (Good Sled)

1978 John Deer Sportfire (Good Sled)

197? skiroule scorpion (got me laid)

 


#13 Doooby

Doooby

    Advanced Member

  • Members
  • PipPipPip
  • 53 posts
  • Sled:Summit x 650 154"

Posted 12 January 2017 - 07:55 PM

Mine ruptured


Sent from my iPad using Tapatalk

#14 defcon13

defcon13

    Advanced Member

  • Members
  • PipPipPip
  • 62 posts
  • Gender:Male
  • Location:Quebec, Canada
  • Interests:snowmobilling, r/c offroad racing, fishing, astronomy
  • Sled:summit x 850 154 2017

Posted 27 December 2017 - 10:58 PM

had the same issue with ice build up in the steering boots and rods today to a point where it locked up. luckily i was not far from home but still had a hard time steering the thing to get back home. removed the ice and found that my two steering rods are slightly bent.  :mad_old: i dont know if i can straighten them or i need to install new ones...



#15 summitx411

summitx411

    Advanced Member

  • Members
  • PipPipPip
  • 603 posts
  • Gender:Male
  • Location:Canada
  • Sled:17 Summit 850, 05 MXZ 500SS (SHR660)

  •    

Posted 27 December 2017 - 11:22 PM

Noticed my mag side was wrecked. Not sure how long it was like that, I have the brp skid plate. Hopefully the dealer steps up.

Sent from my SM-G935W8 using Tapatalk





Also tagged with one or more of these keywords: boot, G4, 850

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users