800r ptek with 4mpg fuel mileage - Page 2 - REV-XP / XS Chassis - Performance Trail 120-129 Inch Models - DOOTalk Forums

Jump to content

 






Photo

800r ptek with 4mpg fuel mileage

800r poor fuel mileage carburetor

  • Please log in to reply
22 replies to this topic

#16 windsurfnut

windsurfnut

    Windsurfnut

  • Members
  • PipPipPip
  • 1237 posts
  • Gender:Male
  • Sled:2020 MXZ X-RS 850

Posted 14 February 2019 - 09:39 AM

Take a really a close look at RAVE valves, make sure they suck in tight at start up.  Solenoids and check valves go bad.  Chased that problem for 2 seasons before I finally replaced the solenoids and check valves and MPG and power all came back.


2022 Ski Doo MXZ 600R X (Wife's)

2014 Ski Doo MXZ 600 Etec TNT (Kid's)

2011 Ski Doo GSX LE 600 Etec (Kid's)

 

Previous Sleds:

2006 Ski Doo MXZ 550 X (Kid's)

2016 Ski Doo MXZ 800 X-RS

2014 Ski Doo MXZ 800 X-RS

2012 Polaris Rush 800 Pro-R LE (what was I thinking!)

2009 Ski Doo MXZ 800 X

2007 Ski Doo MXZ 800 Blizzard

2001 Ski Doo MXZ 700 X

1998 Ski Doo MXZ 670

1993 Ski Doo Formula STX 583

 


#17 Tollefry1

Tollefry1

    Member

  • Members
  • PipPip
  • 18 posts
  • Sled:2009 MXZ X 800R

Posted 14 February 2019 - 09:12 PM

So the sleds been in the garage since sunday, it's almost fully defrosted. It's about 25f in the garage tonight. I took the covers off and pushed on the pistons, they were super stiff but i could push them in, they moved back out on their own. I fired up the sled, the pistons did not move. I let it run for 2 minutes, they still did not move. I then pushed them in, and they stayed in. I noticed a big difference in the exhaust sound, much quieter and not so much popping. I shut the machine off, checked the pistons, they had returned to mid position. I then fired it back up and saw that the pistons were in. thoughts?



#18 Thumb2bar

Thumb2bar

    Advanced Member

  • Members
  • PipPipPip
  • 4459 posts
  • Gender:Male
  • Sled:16 Gade800X,09 800x 120,18 850x 129

Posted 15 February 2019 - 07:25 AM

It may be just sticky valves, start there by pulling them and cleaning them as well as the slots they ride in. In your case, they seem to function when the goo is warm though.

#19 Ride 670

Ride 670

    Advanced Member

  • Members
  • PipPipPip
  • 32 posts
  • Gender:Male
  • Location:Sioux lookout
  • Sled:09 summit 800r

Posted 17 February 2019 - 02:16 PM

Ptek engines did have a problem with DPM, I believe it was a vacuum activated solenoid or valve. There was a bulletin on the 2009's, not sure if it was sorted out for 2010. Maybe have your VIN run by dealer to see if yours is affected. I don't think jetting would suddenly cause that much of a drop in mileage. Maybe you've got a bad needle/seat causing a very rich condition?

Does anyone know the service bullet im curious as well



#20 Tollefry1

Tollefry1

    Member

  • Members
  • PipPip
  • 18 posts
  • Sled:2009 MXZ X 800R

Posted 24 February 2019 - 12:56 PM

It may be just sticky valves, start there by pulling them and cleaning them as well as the slots they ride in. In your case, they seem to function when the goo is warm though.



#21 Tollefry1

Tollefry1

    Member

  • Members
  • PipPip
  • 18 posts
  • Sled:2009 MXZ X 800R

Posted 24 February 2019 - 12:59 PM

Hooked up the gopro and saw what's going on.the raves open up quick at wot, but when throttles closed, the power valves stay open for 5-10 seconds. This seems like a very slow response especially when running trails. Any thoughts, I just cleaned them last summer.

#22 Tollefry1

Tollefry1

    Member

  • Members
  • PipPip
  • 18 posts
  • Sled:2009 MXZ X 800R

Posted 26 February 2019 - 12:21 PM

So I decided to tear in to the solenoids last night. Removed the muffler and plastic guard. Cut away a few plastic ties. disconnected the electric plugs. Found a spare 12v battery. Direct wired the battery to the solenoids. Both solenoids clicked. The rear solenoid clicked loud, the front solenoid clicked soft. Pulled the front solenoid out, retested still a soft click almost cant hear it. I think my issue is the vacuum side since my raves stay open too long. I finally found a diagram showing which solenoid does what, unfortunately I pulled the pressure solenoid. Going to buy 2 new solenoids now. Will put back in, reassemble, and retest. 



#23 Daag44

Daag44

    Advanced Member

  • Members
  • PipPipPip
  • 27752 posts
  • Gender:Male
  • Location:South Shore, Quebec
  • Interests:1973 Olympic
  • Sled:2007 1000 SDI

Posted 26 February 2019 - 09:06 PM

Hooked up the gopro and saw what's going on.the raves open up quick at wot, but when throttles closed, the power valves stay open for 5-10 seconds. This seems like a very slow response especially when running trails. Any thoughts, I just cleaned them last summer.

 
 

So I decided to tear in to the solenoids last night. Removed the muffler and plastic guard. Cut away a few plastic ties. disconnected the electric plugs. Found a spare 12v battery. Direct wired the battery to the solenoids. Both solenoids clicked. The rear solenoid clicked loud, the front solenoid clicked soft. Pulled the front solenoid out, retested still a soft click almost cant hear it. I think my issue is the vacuum side since my raves stay open too long. I finally found a diagram showing which solenoid does what, unfortunately I pulled the pressure solenoid. Going to buy 2 new solenoids now. Will put back in, reassemble, and retest.


Brilliant on all counts!!!
 
You have learned the value of the eRAVE Position Sensor on the ETECs and the 1000 SDI. The cool thing about the ETECs is that you can monitor the position sensor with a multimeter.... or a GoPro ;) 
 
As a comparison, to show the eRAVE opening on the 1000 SDI, a micro-switch needs to be added to the actuator with a 12V incandescent light for a mechanically triggered pilot light. For the 800R PTEK I need to find out if I can incorporate the Position Sensor of the ETECs to add a pilot light like we do with the 1K. The 800R PTEK and ETEC are essentially the same engine, so it shouldn't be difficult to rig with OEM parts. The 800RE (ETEC) part-outs are slowly becoming common, so it should be easy to find for a reasonable price.
 
In your case - and in my opinion - you have chosen the best path by replacing both solenoids. I recently spent hours cleaning and testing the eRAVE system on an 800R PTEK like yours. I can afford extra time to do this work, but I can't afford a $3000 repair to fix a $3000 rebuild. Of course I'm not talking about a $200 SPI top-end repair, but rather a genuine build. That would total $6,000 on an old sled that is not under warranty, not to mention that it getting close to paying for a brand new 850 that is not even in the same sandbox. The 850 and 600R has upped the game so far that our old sleds no longer compare. That is why if I spend a dime on an old 800R that I make sure it is working right.

Air/Fuel Ratio for two and four strokes
Air/Fuel Ratio for 1200 with boost
Air/Fuel Ratio is measured through emissions
Wideband and EGT
Wideband readings of Air/Fuel Ratio on a two stroke
600 SDI MY2004 Lean/Hot spot running 6900-7000 rpm @ 40-45% Throttle Opening
800R Cranking Compression
800R Oil Injection / Premix combo
800R P-TEK Electrical Troubleshooting #1 and #2 
800R Turbo
850 Center Oil line for coolant pump melted
850 Main Oil line caught fire #1 and #2
900 ACE Turbo - muffler turning red hot
1200 4-TEC Mapping
1200 4-TEC MY 2009 to 2011 Fuel Line issues that could cause a fire
Batteries
Belt Blowers: Overview of UPMICHIGANDER's and Ronn's experience
BUDS 3.3.0 won't connect to SDI
BUDS not connecting to HO or SDI - Try a CanDoo
Crankshaft runout - maximum allowable specs 
CVT efficiency - BlueMax
Deep snow intake for XP chassis
Electrical - ECM drivers for Ignition Coils and E-TEC injectors 
Electrical - Diagnoses of a failed ECM
Electrical - 30A Battery Charging Fuse Socket Diagnoses and Relay
Electrical - Relay Coil Wine
Electrical - Relay Testing
Electrical - Battery Charging Relay Diagnostic 
Electrical - Troubleshooting with BRP video 
Electrical - Solder vs Crimp
Electrical - Diagram for Fanners on page 3
Engine Break-In 
Engine Weight 
E-TEC 600HO Clutching
E-TEC Oil Pump
E-TEC Dial-A-Jet
E-TEC Electric Start troubleshooting
E-TEC Engine Management
E-TEC eRAVE position code recurring
E-TEC Stator fault codes P1562 or P1563
E-TEC Capacitor Charge Hold Test and Residual Voltage Test
E-TEC Voltage Rectifier Regulator troubleshooting
E-TEC Power Fades are not normal and can be fixed
Fuel Issues: Could new Ester type oxygenated additives be deteriorating the Fuel Sender Grommet?
Fuel pump and regulator replacement for ACE, E-TEC and SDI
Gasoline quality and storage
Bad Gas for a Two Stroke - Is it a Myth ?
GNR CVT Alignment for the G4
Grip N Rip Clutch Alignment testing
G4 Clutch Alignment, Engine Movement, Sheave Runout and Clutching
G4 850 Throttle Jerkiness solved with clutching
G4 850 Snappy throttle/clutch engagement
G4 850 pDrive tech - A question of Engineering
G4 Steering
G4 850 Tuned Pipe @ 12.6 lbs and Muffler @ 15.4 lbs vs 800R and 800RE muffler weight
Longevity - 800R E-TEC 
Mikuni o-ring for carb float assembly - Arctic Cat part# 6505-875 or from Amazon and eBay
Muffler Red Hot
Off-trail riding for flatlanders
Oil versus Fuel consumption
Pictures - How to resize and upload to DooTalk
Pictures - How to post with the correct orientation
Pipe Pressure testing on a dyno
Pipe Pressure testing from LRD (#1) and (#2)
Pipe Pressure testing results from BRP
Power Loss - How to diagnose in the field
Power at the Crankshaft vs Track - BlueMax
Power Curves: 600 HOE (E-TEC)
Power Curves: 600 vs 800 vs 850 vs 1000 vs 1200
Power Curves: 1000 vs 800 vs 600
Power curves: 800RE 2010.5 to 2016 vs 2016.5 850
Quebec/NY State border crossing
REV Gen1 Gauge Display stuck on "SCALE"
REV Gen1 Volt and Temp Gauge install
REV Gen1 electrical connectors for sensors and MPEM (Multi Purpose Engine Module)
Seafoam for E-TEC injectors
Shortblock or Rebuild?
Ski-Doo Snowmobile Tech Training
Spark Plugs cracked
Squish - The limit
Squish - A discussion on head design
Stator and Relay Diagnostic 
Stator testing for E-TEC using a T harness/Bridge
Stator testing for 1200 4-TEC
Stator Removal on page 3
Stator replacement for a 1200 4-TEC
Suspension Adjustment
Triples - Coolant Pump Assembly
Y-Pipe bolts loosening fix






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users