Jump to content

 




Click here to win this sled



Photo

12V receptacle on Expediton Sport ACE


  • Please log in to reply
3 replies to this topic

#1 BETAK

BETAK

    Advanced Member

  • Members
  • PipPipPip
  • 52 posts
  • Gender:Male
  • Location:Y-K Delta, Alaska
  • Sled:'12 Expedition Sport ACE, '08 GTX 550f

Posted 14 April 2012 - 12:01 PM

I've got a BRP 12v receptacle to install on my expedition sport ACE machine. I'm having a difficult time locating the connector I'm supposed to connect it to. The instructions for getting to it seem to be more for appropriate to other engine configurations. Has anyone done this and, if so, how and where did you locate it? I'm not interested in doing a direct battery connect.

#2 lonewolf 360

lonewolf 360

    Member

  • Members
  • PipPip
  • 13 posts
  • Sled:600etec tundra extreme

Posted 15 April 2012 - 11:36 AM

there should be a spare connector next to the starter solenoid , also one on the left hand side on top of the air box sensor, if you do hook this up direct to these it will only turn on power to items when you are over 3000rpms , also if you use it for a GPS it will have to be turned back on evertime you start you sled up, the direct connection to the battery is the better option , just use a fused line on the positive line to the battery, hope this helps you out.

#3 lonewolf 360

lonewolf 360

    Member

  • Members
  • PipPip
  • 13 posts
  • Sled:600etec tundra extreme

Posted 15 April 2012 - 11:49 AM

there should be a spare connector next to the starter solenoid , also one on the left hand side on top of the air box sensor, if you do hook this up direct to these it will only turn on power to items when you are over 3000rpms , also if you use it for a GPS it will have to be turned back on evertime you start you sled up, the direct connection to the battery is the better option , just use a fused line on the positive line to the battery, hope this helps you out.



#4 fishermann222

fishermann222

    Advanced Member

  • Members
  • PipPipPip
  • 55 posts
  • Gender:Male
  • Location:Bethel, AK
  • Sled:2012 Expedition sport ACE

Posted 15 April 2012 - 10:35 PM

I don't know how to install it but I did not do a direct connect, put on 2400 miles this winter with a GPS on most of the time, just have to remember when you slow down below 2000 rpm's to hit a button on your GPS to tell it it is "ok" that you went from a connection to battery power. It has not been much of a hassle for me this season.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users